5

I use an iPhone and a Mac. I set up text forwarding on my phone so that I can text from iMessage on the Mac, but I noticed that my phone and computer are not always in sync. For example, I'll get a text to my computer, but it won't show up on my phone. Also people who receive my messages say that sometimes they come from my email (the @gmail.com below) instead of my phone #. I posted screenshots below of my settings from my phone and computer. Ideally, I would like all texts to be send from my phone # and my computer and phone to be in sync. Thanks in advance for your help!

enter image description here

iMessage settings from computer: enter image description here

  • I think that, in section "You can be reached for messages at:", you should also see your phone number. Is it displayed somewhere? – mgiordi Nov 22 '15 at 18:58
  • @mgiordi i was looking for that option, but i dont see it anywhere – Kirby Nov 22 '15 at 19:00
  • Have you tried to sign out and log in again in both devices? (be careful that this may have a cost). – mgiordi Nov 22 '15 at 19:29
  • @mgiordi i haven't tried that. what would be the "cost"? – Kirby Nov 22 '15 at 19:32
  • When you log in in your iPhone, you will receive a SMS and so it may cost (I have an Italian SIM and the Server is placed in UK so I had to pay something like 20 cents for the SMS). – mgiordi Nov 22 '15 at 19:34
10

You need to sign up to use you appleID for iMessage with same appleID that you use with your MacBook (@aol email) on the phone.

This can be done by going to settings -> messages -> send & receive; and tapping the option, which reads something to the effect of "use appleID for iMessage".

Once it logs in and activated, Apple will associate the phone number with your email address and it should show up on the Mac. If it doesn't, try logging out and back in from iMessage on the Mac.

  • 1
    thank you. this was correct except i had to go to settings -> messages -> Send & Receive -> use appleID for iMessage – Kirby Nov 23 '15 at 0:55
  • Thank you, I've updated my original answer with that correction for future readers. Glad it worked and your problem is fixed! – Vitalydotn Nov 23 '15 at 1:49
0

GO to iPhone, go to settings for iMessages and select log into iMessages using your apple id. Once I did the it automatically affiliated my iPhone number to messages and FaceTime on all devices log in with that apple id.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .