Macbook Pro 13" 2015 with OS X Yosemite on board. I've been trying to install OS X El Capitan, but always get the following message: "This copy of the Install OS X El Capitan application can't be verified. It may have been corrupted or tampered with during downloading."

By the way this is not a date time issue, date is correct on my computer.

enter image description here

How can I fix this? Who knows the solution, please help.

  • Have you deleted the "Install OS X El Capitan" application bundle and downloaded it again? Commented Nov 22, 2015 at 17:21
  • & where did it come from?
    – Tetsujin
    Commented Nov 22, 2015 at 17:25
  • 1
    @user3439894 I'm actually trying to download it again. Internet connection is poor, so I'm waiting. And yeah, there is no previous copy of the installer app in /Applications/ directory.
    – presscorp
    Commented Nov 22, 2015 at 17:26
  • 2
    If you're already doing as the message suggested and haven't finished the new download and tried installing again, then why did you even post to begin with? If you're having trouble with maintaining a constant connection or have a connection fast enough to get it downloaded in a timely manner you may need to find a better connection for the download. Commented Nov 22, 2015 at 18:12
  • 1
    Try using a USB installer?
    – Munesawagi
    Commented Mar 22, 2016 at 21:40

13 Answers 13


To save having to scroll right down to the newest answer to find this info…
Apple rebuilt all the installers in about 2020 to fix this issue once & for all - see Apple KB - How to Download macOS

Follow this tutorial. This applies to the reply from @Cazuma Nii Cavalcanti. In short once you are at the first install page go to tools in the nav bar and open the terminal, in the terminal type date MMDDHHmmYY replacing the letters as follows.

MM - 2 digit month  01 - 12
DD - 2 digit date   01 - 31
HH - 2 digit hour   01 - 24
mm - 2 digit minute 01 - 59
YY - 2 digit year   > 15

once that is done go through the install normally. I just tried it and it worked with a USB install of OS X (10.11 - El Capitan) and it worked like a charm!

If setting to correct date doesn't work. Set to a date just after the os release.

  • 5
    This should be the accepted answer.
    – Chris Beck
    Commented Feb 2, 2016 at 4:22
  • 10
    The installer date made a big difference for me. When I set the date of the machine close to the date of the installer, installation proceeded with no difficulties.
    – user171792
    Commented Feb 18, 2016 at 6:16
  • 2
    Setting a date near to the date your downloaded the installer , is a solution for fix the message and OS X El Capitan install begin normally and finish ok.
    – user172064
    Commented Feb 20, 2016 at 0:42
  • 10
    I just met the same problem. After set the date to today (2016-02-29) it still failed. Then I set to an earlier date (2016-01-01) and it worked. Weird.
    – aleung
    Commented Feb 29, 2016 at 15:56
  • 21
    Works great. I said date 0101010116 and away we go.
    – matt
    Commented Nov 2, 2016 at 14:11

If you are confident in the integrity of your installation media, you can use the terminal to bypass this message completely. The below instructions are for installs performed via a bootable USB stick:

  1. From the top menu bar, open ApplicationsTerminal
  2. Enter: installer -pkg /Volumes/Mac\ OS\ X\ Install\ DVD/Packages/OSInstall.mpkg -target /Volumes/"XXX" where XXX is the name of the disk you're installing to.
  3. Press return and wait for the installation to say it's complete. You will not see any sort of progress display.

This allowed me to install El Capitan a couple of weeks ago. I didn't have any internet access at the time, and my Mac had a completely empty hard drive, so I was very happy that I could force the install to go through.

I suspect that this method could be adapted for live installations, but failing that, consider creating a bootable installer and then following the above instructions.

  • This is simpler than mucking with the system date and just as effective. I format my hard drive in recovery mode and then boot with command held down and my bootable installer plugged in. Launch the terminal and run the command. Takes a few minutes. I've installed El Capitan several times this way. Best part is, I keep reusing the same installer and never have to worry about the fact that I downloaded it 2 years ago. I'll never upgrade! Muahahaha...
    – Jared
    Commented Mar 15, 2018 at 19:50
  • 2
    One small detail that I missed the first two times I tried this is that OSInstall.mpkg has an m in it. It's .mpkg not .pkg Commented May 22, 2018 at 21:02
  • This one works. Hassle free. Just make sure you type everything correctly. That was my only problem.
    – Afrowave
    Commented Jan 2, 2020 at 9:57
  • This answer worked for me. As Jared notes, it's a time-saver as well.
    – Parapluie
    Commented Jan 16, 2022 at 1:07
  • Tried everything else, this is what worked. Thank you! Commented Apr 26, 2022 at 23:14

I ran into this problem. I had installed a brand new SSD; I downloaded the installer and created a bootable USB stick. Everything looked raring to go. Hours later...

The ways to resolve this process:

  1. Try setting the date to today's date as documented EVERYWHERE. If the install still fails:

  2. Use htiutil to verify the checksum. Assuming you have the El Capitan download in the Applications folder, you can verify the download with the following command:

    hdiutil verify /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg
  3. When did you download the installer? Apparently my problem was that I had downloaded the installer a number of days ago and the certificates had expired. If setting to today's date does not work; and the htiutil command came back with "is VALID"; try setting the date to the date your downloaded the installer.... or possible a few days earlier. I did that, and the install completed with no problems....

Good luck!

  • 5
    Indeed, changing the date to the date of the download make it work, I recommend using Wikipedia to check the release version in order to change the system date. Commented Mar 11, 2016 at 8:34
  • 1
    dude, god bless you, you saved my life :)
    – Isaac
    Commented Feb 27, 2017 at 18:53

By the way this is not a date time issue, date is correct on my computer.

I think many people think setting the date to the current date automatically fixes the issue, but this is not the case. You have to remember the date you installed "El Capitan OS X installer.app" into your Application folder. For me, it was around Sept 2015. Right now is March 2016. When I got this error while reinstalling El Capitan OS X, I set the date to today's date (i.e. date 03061225616) and it did not work because I installed "El Capitan OS X installer.app" around Sept 2015 and the digital signature/certificates for my installer had expired by now. Once I reset the date to Sept 2015 (i.e. date 0923020415), the installation worked without a problem.

If you can neither remember nor correctly guess the date you installed "El Capitan OS X installer.app" into your Application folder, then you would have to delete it and reinstall it into your Applications folder so that the digital signature/certficates for the installer is no longer expired.

Also, setting the date manually in the terminal (i.e. date MMDDhhmmYY) worked for me. I heard setting the date automatically in the terminal (i.e. ntpdate -u time.apple.com) works for some people, but not for me. It most likely worked for them because they recently installed/reinstalled "El Capitan OS X installer.app" into their Application folder

This is the one that worked for me . I went to the terminal and typed

This as the date 0923020415

Using command “date 0923020415 “ and it worked .

  • This was exactly my problem. I downloaded the installer in Nov 2015 and setting the date properly (May 2016) would always fail. As soon as I changed it to Dec 2015 it worked great. Thanks so much!
    – Geesu
    Commented May 17, 2016 at 21:09
  • Yes! My date was correct. I was connected to the internet (after first not being connected), but it wasn't working. But, it still wouldn't install, but this worked perfectly. Commented Dec 22, 2016 at 20:55

Actually there are two known possible causes for this message the show up. One is the obvious corrupted installer. Another less obvious and more tricky cause can be a reset internal clock in the machine, with a resulting date which is previous to the release of the OS installer, what will trigger this message too.

Hope this can help someone.

  • 5
    And a third just confirmed personally: the clock on the computer has to be set to a date near the date of the download. It may be that the installers just have a timeout built into them so there's likely a range of valid dates but setting the clock to the day of the download worked for me.
    – Perry
    Commented Apr 17, 2016 at 21:00

I have found the solution for “This copy of the Install OS X El Capitan application can’t be verified. It may have been corrupted or tampered with during downloading” error!

If you have tried changing the date / time / on a startup disk, forget about it... Make sure you have an internet connection about 10Mbps at least. What you need to do are as follows :-

  1. Restart your mac. Press the Shift Key
  2. When you see apple logo, release the Shift Key
  3. You will go into SAFE MODE. Install & Download your OS X El Capitan in SAFE MODE.
  4. Make sure you delete existing 'Install Os X El Capitan.app' in Application
  5. Re-download the updates of Os X El Capitan.
  6. After finish downloading, everything is ready to go. Success rate 100%.
  7. You might experience the progress bar hanging around 80-90%. (Tested to let the progress bar run but no avail.)
  8. Force Restart again. Press the Shift Key
  9. When you see apple logo, release the Shift Key
  10. You will go into SAFE MODE again. Now let it run until you see the login screen!
  11. When you've seen the Desktop, that means everything is perfectly fine!
  12. Restart again and press nothing!
  13. Now you have an updated copy of OS X El Capitan!

** For Upgrades only **


you could set the time with the date command, but you have to figure out the crazy format and type it in. There's a much easier way.

  1. Connect to wifi, then
  2. run ntpdate pool.ntp.org
  3. you can verify the time is set correctly by running date. Mine was set to the wrong timezone, but that doesn't really matter.

That's all I had to do to get my install to work.


Apple installers have a 'best before date interally'

I just bought a used imac, and wanted to update it from Mavericks to Yosemite. This is what I did:

  • System Preferences -> Time and Date

  • Uncheck set time automatically.

  • Set time and date to 1 January 2014

  • Run the installer. No longer corrupt.

  • Set time and date back to automatic.

For Yosemite the critical date has to be before some time in February 2014. Other updates will be different. I think you have about 3 months after the next version is officially released.

  • Can you update your answer with some evidence from Apple about 'critical date' as well as the Feb 2014 date you mention? I've never heard of this before and it would help if your answer had verification.
    – fsb
    Commented Oct 19, 2016 at 15:56
  • This answers makes zero sense. You can still download Yosemite (and Mavericks, and...) from the Mac App Store. It isn't like iOS where Apple stops signing installations from older versions after a certain date.
    – tubedogg
    Commented Oct 19, 2016 at 17:26
  • 3
    You cannot download Yosemite if you didn't download it once before. A downloaded copy will not install without the date change on the 4 machines I've done this with. you can test this: Create a new apple ID from a throw away address. Log in with that address into appstore. Try to find the Yosemite install file. It is possible that the problem is keyed to the C-time of downloaded file. Commented Oct 21, 2016 at 0:01

March 2017 Success Confirmed This answer is relevant because: The solutions above did not (completely) work for me. Apple may have changed its check routine and date stamp in 2017. It offers an addition to reach a working solution.

MacBook Pro Quad 2.4GHz i7 Late 2011, 16GB RAM, 500GB SSD, original 750GB HDD. Running OS 10.8 initially. After 4 years, time to upgrade the MacBook Pro which I run as a graphics workstation through a 27" monitor and standalone full size keyboard. Adobe CS6 and Office 360 are the major software. Hardware completed no issues (SSD into optical bay / 2 x 8GB Ram chips). For the OS I decided on El Capitan 10.11 since it is reported to have system / performance enhancements and Sierra is a step too far, turns too much off on this Mac.

Issues on trying to do this are well documented so I wont dwell, other than to say my last App Store download was 10.8 and so I wasn't 'allowed' to download 10.11 officially, even though it is more appropriate to my Mac than 10.12. This isn't about money or subversion. I would gladly pay for an official disc or download. I simply could not get one.


1) You will need the base installer application for El Capitan (which is what you would download from the app store if allowed). You can either get this off a Mac colleague (who has downloaded it previously), ebay, or Hackintosh (which is an unofficial website dedicated to running OSX on a Windows box).

Obviously certain risk involved here. Use a proven source, don't torrent. Waste of time and may be corrupt / subverted which just causes more frustration. Once you have the application put it in your applications folder.

Note: if you are concerned, run the Terminal verification command on the installer as noted by pRose_la above (credit due). Ensure it reports Verified on conclusion.

El Capitan installer app

Note: The app wont work at this stage. If you launch it you will get an endless 'verifying installation' bar or the screen noted in other posts (corrupt or tampered installation). Time stamp will be out of date.

2) Create a boot volume on an external USB Flash drive. This must be 8GB+ capacity. This is allowed by Apple and they give you the terminal code to do it here: Apple create an external boot drive

Note: the El Capitan installer must be in the Mac's root application folder for this to work as the terminal command goes there to get it. Also the Flash drive must be formatted with a GUID partition to boot the OS (El Capitan on Flash boot drive).

Note: there is an GUI app to do this for you DiscmakerX but its buggy and failed consistently for me with no indication to the problem (paths were correct, formatting correct).

3) NEW 2017: this is the addition to the process. At this point, I could boot remotely to Flash drive, access terminal to circumvent the date issue, launch the El Capitan installer. However, it would always get to 99% installation and then crash, sometimes with a final message - this installation is corrupt. I examined the El Capitan Installer app (right click the installer app / show package contents) and noted a folder called _CodeSignature. I went to my 'official' 10.8 installer app and lucked out... the same folder was in there. To be clear:

I copied the _CodeSignature folder from inside Install OS X Mountain Lion.app to the same position inside Install OS X El Capitan.app on the Flash drive.

enter image description here enter image description here

4) Restart the Mac with option (alt) key pressed and you will be presented with bootable volumes. Select your Flash Drive using the keyboard arrow keys and press enter. Give it 5 mins to boot up. Don't get impatient. The remote installation now went through perfectly. I have 10.11 installed on an SSD partition and updated to the latest version through Apple app store.

Note: You still NEED TO RESET THE DATE in terminal after your Flash drive boot and before you launch the El Capitan installer to bypass the initial date certificate issue. Details in posts above, remain valid. Set mine to the day after the application download date (find this date with Get Info on the installer app itself).

Conclusion This process worked for me in March 2017 on a late 2011 Mac running OS 10.8. I now intend to create remote installers for Yosemite and Maverick just in case I need them for my other Macs in future. Do I feel bad about this hack? Not really. Disappointed that I have had to go to these lengths to update a perfectly good Mac that cost me in excess of $4000... because I didn't choose to upgrade last year.

  • Off topic but useful intel for upgrading physical performance to match the heavier OS, the move to SSD in the optical drive offers a HUGE speed advantage on a late 2011 MacBook Pro as the optical drive bay connection is rated at 6GB/s (early models were 3GB/s) - the Crucial MX300 SSD is pulling (read/write) 395.2 / 413.6 MB/s compared to the Apple stock shipped drive internal bay @ 55.4 / 70.6 - you will need a caddy for the optical bay and you can of course buy two matching SSD's and Stripe RAID them to improve speed further. Commented Apr 13, 2018 at 14:11
  • The fact that this info is useful does not make it relevant to the question. You should ask and and answer your own question so that this information can actually be found by the people who need it! Commented May 9, 2018 at 15:36

If you get this error message it is most likely not a problem with the installer, but rather an expired certificate.

Please see the article "Previously Downloaded OS X Installers No Longer Work". Fortunately, there is a very easy workaround for this.

"...due to an expired certificate, OS X installers downloaded prior to 14 February 2016 won’t work.

The Apple Worldwide Developer Relations Intermediate Certificate is required for all apps in the Mac App Store, including OS X installers. When used to sign an app, the certificate enables OS X to confirm that the app has not been corrupted or modified by an attacker. This certificate expired on 14 February 2016, causing error dialogs and preventing some apps from launching. Most affected apps have already been updated with the new certificate. But if you downloaded an OS X installer in case of trouble, you may be in for a surprise the next time you try to use it."

The above article was linked from here: "This copy of the Install OS X Yosemite application can’t be verified. It may have been corrupted or tampered with during downloading. | Need Help 4 Mac"

If you set your Date & Time prior to the date mentioned above before installing you can bypass the hitch, and the installer works normally. Simply set it back after the installation is complete and you're good to go. If you purchased an older OS like Yosemite before it was removed from the App Store it can be re-downloaded from the Purchases tab in your App Store account, and it should have an updated certificate.


These issues have long been fixed, as of 2022. Apple rebuilt all the installers.

Get new installers from Apple KB - How to Download macOS
These no longer have the certificate/expiry issues.


I encountered the same issue when performing a clean install on a new hard-drive. Most likely it was caused by disconnecting the battery in order to safely install the hard-drive. After setting the date the install was successful.

  • for El capitain, when installing, Open terminal and set date to aug 2015 date 080610102016
    – ingconti
    Commented Jun 26, 2018 at 21:59

Here's what I went through. As long as I erased my Mac and "bootable usb El Capitan install drive" installation process complained with verification problem I decided to reinstall "Yosemite" using the built-in recovery disk, then I downloaded installer for "El Capitan" from "App Store". It was not possible to install through the "bootable usb drive" again, so I updated to El Capitan, oddly worked. And finally I erased my Mac and repeated reinstallation for "El Capitan".

  • 3
    This answer outlines a convoluted process that does not get at the heart of what the problem was or why; not to mention that it is a huge waste of time. Commented Jun 26, 2016 at 13:09
  • It's just the way it is.
    – presscorp
    Commented Jun 26, 2016 at 14:44
  • What a huge waste of time? Commented Jun 26, 2016 at 15:33
  • The point is that None of the answers were helpful until the date when I found the solution. So at that time I solved it on my own. I didn't check other answers which showed up later, cause the problem doesn't bother me anymore.
    – presscorp
    Commented Jul 9, 2016 at 5:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .