3

I have a 4.6GB file on my hard drive. Today when I tried to copy it to another machine through network, I got the following error message from Finder halfway through the copy:

The Finder can't complete the operation because some data in "(name of my file)" can't be read or written. (Error code -36)

In addition to copying that file to another machine through network, I also did the following:

  • checked some other files on my hard drive and found another one with the same problem;

  • tried copying those files to another folder on the same hard drive, and got the same error;

  • tried to open one of those files, which was a .dmg file, by double clicking on its icon, and got a different message when Finder tried to verify it, saying there was an input/output error.

Then I tried the following to fix the problem:

  1. Disk Utility: I ran Verify Disk and it said my disk is OK;

  2. fsck -fy: it also said my disk is OK;

  3. dot_clean as suggested here: didn't work, the error remained.

So what else can I try? Is this an indication that my hard drive is failing?

  • 1
    'read or written' doesn't actually give any indication of which end of the transaction is failing. What is the format of the drive you are copying to, & over what mechanism? FAT32, for example, has a maximum file size of 4GB, FAT16 only 2GB. – Tetsujin Nov 22 '15 at 7:52
  • I tried to copy the file again. Instead of copying to another machine, this time I copied it to a different folder on the same hard drive, and Finder showed the error again. So I don't think it's about FAT32 or FAT 16. Thanks for your suggestion anyway, I'll update my post. – ycsun Nov 22 '15 at 8:02
  • So, are you saying that it could be the file that is damaged? Have you been able to open the files no problem? – MicroMachine Nov 22 '15 at 8:22
  • @fabrice: Yes, it appears that the file is damaged. It is actually a dmg file. When I double click it, Finder tries to verify it, and fails the verification with an error message saying that there is an input/output error. Thanks! I'll update my post again. – ycsun Nov 22 '15 at 8:32
  • 2
    Your HDD is possibly going bad or at the least has some bad spots on its platters. Neither Disk Utility or fsck preform the low-level testing of the entire disk to determine the actual physical state of the surface of all the platters in the HDD. – user3439894 Nov 22 '15 at 13:00

You must log in to answer this question.

Browse other questions tagged .