1

New Magic Trackpad Anomalies?

Bizarre problem here with my new Magic Trackpad with Force Touch. The trackpad pairs via Bluetooth no problem, and shows up as actively connected in the Bluetooth connection window, as you can see in the screencap below:

enter image description here

As you can see above, the trackpad is connected properly.


But the trackpad preferences console fails to find the trackpad, thus displaying the message below for two hours now.

enter image description here

Yes, I've tried turning Bluetooth and the trackpad off, and removed the batteries from the old trackpad. Still, however, it renders the trackpad basically useless; it works, but lags at a slow speed and has none of my preferred gesture settings.

Anybody having similar issues? A fix?
  • Have you tried deleting all Bluetooth devices and re-pairing just the trackpad? – Vitalydotn Nov 21 '15 at 15:33
1

new Magic Trackpad and new Magic Mouse, need OS X El Capitan. In previous versions of OS X, it will pair normally as a HID device, but its particular features won't be available.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .