7

So because the mail app from Apple is far from perfect and never showed me the date and time of calendar invites from MS Exchange environments (after the Yosemite update) I was adviced to re-add the exchange account in Preferences -> Internet Accounts.

After doing that, the calendar app just won't show the exchange account anymore. It's right there in the settings, but not in the panel:

enter image description here enter image description here

Can anyone tell me how I get my exchange calendar back to the calendar app?

Thanks in advance for any help.

PS.: the bug in mail (no date&time for cal invites) wasn't fixed by this btw.

7

I feel stupid for answering this myself because the "fix" is idiotic.

  1. Remove the exchange account
  2. Restart the mac
  3. add the account back -> everything works.

I hope another answer gets two upvotes if they help someone so they're assigned the bounty I put out on this question. Thanks for the answers!

  • 1
    I only had to make it inactive and then reactivate it. No reboot. – Chuck Krutsinger Jun 6 '17 at 20:41
2

You could try clearing the calendar cache and see if that resolves it:

Quit Calendar

Go to ~/Library/ by typing ⌘+⇧+G in the Finder and copying that path into the dialog that shows.

In the ~/Library/Caches/ folder, look for com.apple.ical and move it out to your Desktop (it might not exist).

In the ~/Library/Calendar/ folder look for files named Calendar Cache and move them out to your Desktop.

Reopen Calendar

At this point, you might also want to try disabling and re-enabling your Exchange account in the Calendars Accounts pane.

2

I recently encountered this on a Mac running 10.11 El Capitan. The Exchange account was active in System Preferences -> Internet Accounts and the Calendar was checked to sync, but the Exchange calendar did not show up in the sidebar of the Calendar application.

To resolve this, we deleted the Exchange account in Internet Accounts and then re-added it back in.

1

Select "Enable this account" in Calendar -> Preferences -> Account tab.

  • It looks like it is already enabled, the second image in his screenshot is the Calendars account pane, the Exchange entry would be greyed out if it were disabled. – SJT Nov 24 '15 at 12:21
  • yup, it's enabled. Mail works. – ProblemsOfSumit Nov 24 '15 at 14:55
1

I also had this problem. What worked for me was a hybrid of the two suggested solutions so far:

  1. Go to Calendar -> Preferences -> Account
  2. De-select "Enable this account"
  3. Re-select "Enable this account"

Now the account shows up.

1

I also had this problem. What worked for me was to go to Settings > Internet account. Under Exchange panel, uncheck calendar and recheck it. Then all the events from Exchange appears on iCal.

In my case, changing preference on Calendar itself doesn't work.

1

I had the same issue, but mine was because we had changed from Exchange 2007 to Exchange 365. I had two accounts with the same email one active and one not inn the internet accounts part of the Mac settings, I deleted the in-active account and then I disabled/enabled the remaining account in both Calendar -> Preferences -> Account and internet accounts.

I started to play around with the cache as in the suggestion here but before I concluded on that the email starting synching correctly. One more note, I had the account synch on push.

-1

Reboot worked with Sierra also thanks.

  • Welcome to Ask Different!. Please refrain from adding comments in an Answer. The preferred way of saying 'thanks' around here is by up-voting good questions and helpful answers (once you have enough reputation to do so), and by accepting the most helpful answer to any question you ask (which also gives you a small boost to your reputation). Please see the About page and also How to Answer. - From Review – fsb Jun 30 '17 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .