I am running Lion and I wanted to add certain stocks to the Stock widget. I was able to add them fine and remove the default ones but everytime I go back to Dashboard the Stock widget is reset and the default stocks appear. Does anyone now how this can be fixed?

  • Just random troubleshooting, but check if the plist is corrupted: plutil ~/Library/Preferences/widget-com.apple.widget.stocks.plist. Even if it isn't, try trashing it as well. – Lri Aug 12 '11 at 18:34
  • @Lri 'widget-com.apple.widget.stocks.plist' isn't even there, I must be missing something. – Delphy Aug 12 '11 at 19:27
  • Did you look in the user library (/Users/username/Library/ or ~/Library/) or root library (/Library/)? – Lri Aug 12 '11 at 19:45
  • I looked in all of them... – Delphy Aug 12 '11 at 21:20

If you haven't removed the widget from the widget screen, do try that. Press the circle with a plus on the lower left and then the x on the top left corner of all the stock widgets on your dashboard (you can add more than one). If it's still broken when you add it fresh to the dashboard, you'll have to poke it a bit harder.

The widget isn't going to like this - so you'll have to manually clear out the file where the stocks are recorded.

Get ready to log out so save all your work and quit all apps. Go to the folder below in Finder using this command (or the Go menu) shift+command+G


Move these two files only to your desktop.


Then log out shift+command+Q

When you log back in (or reboot), the widget will make a new container to store your stocks and things should be better. This little dance is called setting aside your preferences (plist files) and starting again with the defaults.

If it works, you can trash the two files on your desktop. If not - you can move them back or not however you prefer. For an app with lots of settings, it's nice to be able to move back the ones you prefer once you've ruled out that file as causing you some pain or other.

  • Both of those files are missing from Preferences. – Delphy Aug 12 '11 at 21:17
  • Wow - then your user account can't write to that folder. Lots will be broken if the widget can't make those files after a clean reboot. Let me see if there is an answer here how to fix the permissions on your Library folder in a safe manner. – bmike Aug 12 '11 at 21:29
  • My other widgets are there though so I'm not sure why it is just the Stocks one. – Delphy Aug 12 '11 at 21:48
  • 1
    If you do the same with another widget, can it create a new plist file? Have you tried removing that widget from the screen using the circled plus in the lower left - delete all instances of the stock widget. Then rebooting. Add it in after the reboot. This sure is odd... – bmike Aug 12 '11 at 21:52
  • 1
    Removing the widget and re-adding it to the Dashboard created the missing files. Thanks for all the help! – Delphy Aug 13 '11 at 1:32

Try re-downloading the widget. This isn't the Apple widget, but you can also try this one.


Go to the ~/Library/Preferences/widget-com.apple.widget.stocks.plist file, highlight the file name and use Get Info (Command ⌘ + I) to change permissions for "Everyone" from "No access" to "Read & Write" This will cause the list to be retained and updates to populate even when the market is closed. The only caution is this: once you have done this, if you remove and re-add the widget, while it will have preserved your list, the re-add will also have changed the permissions for the "Everyone" back to "No access", so you'll need to follow these instructions again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .