1

This question already has an answer here:

Copied all my local notes to Apple's iCloud notes. It's been a few days and they haven't indexed yet. I found if I edit a notes file then it gets indexed. I don't want to edit all my notes apps as they maintain the date of last usage. How can I force an index of all the Apple notes?

marked as duplicate by bmike macos Aug 10 '18 at 0:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

For what it's worth, I copied all my notes from iCloud to "on my Mac" by selecting all the iCloud notes, holding down the option key and dragging them all to "On my Mac". Immediately they were all indexed and searchable. hmm. Oh my, so are the iCloud notes now searchable too. So that copy function must have triggered an indexing command.

Cheers,

Ron

1

Notes are stored in under Library/Containers/com.apple.Notes in your user folder. You can force just the notes to be reindexed by Spotlight using the following command in the Terminal:

mdimport ~/Library/Containers/com.apple.Notes

Tested on macOS 10.11.

  • When you see the same question, better to flag one as duplicate instead of posting the same answer twice. – bmike Aug 10 '18 at 0:53

Not the answer you're looking for? Browse other questions tagged .