3

This is in El Capitan, but problem likely exists in earlier versions.

It's a very simple question:-

How can I create an automount onto a folder/directory with a space in the name?

I'm using my own map file in /etc, referenced by auto_master. It would appear to be correct since the mounts I specify that do NOT contain a space work perfectly.

Docs say escape with '\', or quote the string and I've oft seen '\040' suggested. Nope, they simply fail or just cause a folder to be created with the '\' etc in the actual name. Hopeless. And no, I CANNOT change the name of the mountpoints to eliminate the space.

What's the secret trick to doing this?

  • Double quotes should definitely work. Can you post the contents of your map? – Vitalydotn Nov 19 '15 at 18:30
  • I have this line in /etc/auto_master – UKenGB Nov 19 '15 at 19:58
  • I have this line in /etc/auto_master "/- auto_iTunes_Media -rw,nobrowse,nosuid" and then this in /etc/auto_iTunes_Media "/Users/ken/iTunes/Media/Home Videos MythServe:/srv/mythtv/video/Home_Videos". Quotes are just for here. I've tried escaping the space with '\', \040, %20 but it just puts those chars into the mountpoint name, leaving the space as is means it mounts onto .../Home thinking Videos is an option and quoting it all means it refuses as the first char must be a '/'. I've tried everything I've found that is supposed to work. Any clues? – UKenGB Nov 19 '15 at 20:06

You must log in to answer this question.

Browse other questions tagged .