0

I tried to make a partition for Windows on my Mac by using Apple's Disk Utility, because bootcamp already showed me that it didn't work for some reason. But now I'm stuck with a 70 gb hard disk, and I'm not capable of accessing the other part of the hard disk (I'm using a MacBook Air with 120 GB SSD).

I kind of expected Disk Utility to let me change the name and everything for this new partition I made (intended for Windows), but for some reason, the only thing that happens is that I can't access the rest of my hard disk anymore and there are no more partitions available.

I hope I've made clear what the problem is, I'm not a native speaker (as you might have noticed) so it's a little hard to write a question about a subject like this.

Here is the output of diskutil list:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            120.5 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.1 MB   disk0s3
/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +120.1 GB   disk1
                                 Logical Volume on disk0s2
                                 732FEE77-68E5-4934-AEA2-EB01DE4EA90D
                                 Unlocked Encrypted
  • @coen Please edit your question if you want to add additional informations instead of answering. – klanomath Nov 23 '15 at 7:27
  • What kind of "hard disk utilities" did you use to partition your SSD? Apple's Disk Utility? – klanomath Nov 23 '15 at 7:32
  • okay, sorry! I just couldn't really get the codethingy done... I used Apple's Disk Utility indeed, nothing I have done so far has been done by a peer-made program – coen Nov 25 '15 at 5:21
  • The diskutil list output doesn't reflect the observations you made in your question. The output shows the default partition layout of a CoreStorage LVG with one LV( and a Recovery HD) occupying the whole ssd. – klanomath Nov 25 '15 at 7:53
1

I once had a simillar problem, the disk verification in disk util shown minors errors, but it wasn't able to fix them. As such, I couldn't delete a fat32 partition. Here is what I did :

  • first i booted into safemode. The startup was long as it was fixing errors. (On boot, before startup chime, press and hold Shift)
  • after that i booted in recorvery mode (the same: on boot cmd+r)
  • when the recovery mode shown up, i did load the disk utility and deleted the partition. It worked this way.

However, You Should always do backups of your data, especially if you are messing with partitions

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .