0

iPhone 4s, my iPhone 99% of the time won't charge arms the battery is power-draining. Started happening at random, going from good - absolute hell while i was at work. One time out of the many times I've recently tried, it charged about 10% after hours and hours on the charger. tried 3 separate chargers (3 separate brands), tried draining 100% and charging back up etc. could the battery be shot? I can switch the battery out in a simple minute, but I don't want to go out of my way and buy a new battery at my shop if it won't work

  • All you can really get in answer to that question is "Yes, it's likely to be the battery." It's the best guess & without testing equipment, no-one could say more. – Tetsujin Nov 19 '15 at 6:38
1

Battery certainly could be bad, but there are some other common areas of failure.

If you shine a light into the 30-pin connector, check for any physical obstructions such as pocket lint, scraps of paper, I've even seen staples and gum. If you spot it, try to use compressed air to get it out.

Also look for any burnt (blackened) pins which could explain it.

Lastly look for signs of liquid. Liquid LOVED getting into those docks. Signs of liquid include corroded (green) pins, or tripped (red or pink) liquid contact indicator. The liquid indicator is in the center, under the connector plate.

Barring any of those things, it's most likely either the battery or the charging circuitry.

  • It looks like there might possibly be 3 black pins, but I have to do some research on that. What does a black pin mean? – user137418 Nov 19 '15 at 11:08
  • Also, I looked where you said liquid indicator is. Looks like a hole chipped out of the white square that the connector plate is attached to? If so, the hole is pretty gunked up, almost looks like I can see a metal mesh somewhere in there – user137418 Nov 19 '15 at 11:13
  • To update, just checked the 4s after having left it plugged in while I was at work. 10 hours +\- 2 has gotten it up to 44%. Turned on wifi while on airplane mode to start backing stuff up to Google Drive, and 2 minutes max has brought it down already 4% – user137418 Nov 19 '15 at 11:33
  • A black pin is a burnt pin which could very well explain it. If you count which pins are burnt, you can compare it to the pinout and see if that's correct. For the LCI, if you blow it with compressed air (sometimes you have to use a brush to get gunk out of there) you should see either a white or red/pink square in there. Shouldn't be a metal mesh. – Vitalydotn Nov 19 '15 at 13:36
0

You didn't mention which iOS version you are running. With iOS 9 you can have a look at which application is using the battery the most (in Settings/Battery).

In general I would recommend a full reinstallation of the whole phone in such situations. But as the 4s is rather old so is probably the battery, which would explain the behavior you are seeing. Going for a new one sounds like a good idea (especially if you can replace it yourself).

  • Running iOS 9. And I replaced the battery around 9 or so months ago, could it still just instantly change like that? – user137418 Nov 19 '15 at 11:07
  • Hard to say. Based on the information you've shared so far a faulty/aged battery seems to be the best guess to explain the symptoms you are describing. – nohillside Nov 19 '15 at 12:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .