1

Lately Apple Software Update has been popping up with a recommended upgrade to iCloud 5.0. (I am currently on 4.1.1.53, on Windows 10 with the Fall Update).

Each time I attempt to upgrade, the upgrade fails.

I tried uninstalling the application using the uninstall utility, but that failed as well.

Finally, I tried to "Repair" the program, but that did not work either.

Any other suggestions? At this point I just want iCloud off Windows for good.

1

Try to remove manually all the file in:

  • c:\program files x86\common files\apple\internet services or
  • c:\program files\common files\apple\internet services

Then, via https://discussions.apple.com/message/29281327#29281327 -

  1. Press Win + R (the "Run" prompt should appear)
  2. Type "regedit" (for the registry editor) & press enter.
  3. Make a registry backup first: press File > Export and save current state of registry
  4. Find and delete all folders containing "icloud"

Finally, you should be able to restart the computer and download iCloud from the Apple Web Site

iCloud for Windows

Reinstall the program.

| improve this answer | |
  • I tried this, but I could not delete ShellStreams.dll or related files because they are loaded by Windows Explorer (for Photo Stream). After deleting everything but that, I attempted reinstalling, which failed with error 2343. – drkokandy Nov 19 '15 at 6:08
  • This error 2343 seems to be tied to having Outlook 2016 - discussions.apple.com/message/29201074#29201074 - and apparently the "solution" is to install an older version of Outlook. I'm not going to buy an old version of Outlook (I have 365) in order to upgrade iCloud. Thanks for trying to help, but this appears to be the completely insane solution, for anyone else who stumbles upon this thread, – drkokandy Nov 19 '15 at 6:12
  • Okay, with this suggestion, I was able to successfully install iCloud 5.0: discussions.apple.com/message/29281327#29281327 - I'm going to try to edit your answer to add this detail, and then I should be able to mark it solved. – drkokandy Nov 19 '15 at 6:36
1

After struggling with this for a few hours, I finally came up with something that worked: when it stops on "removing backup files", go to the task manager and kill the msiexec.exe process. That kills the installer completely, before it has a chance to "roll back" the install. After that I found that the icloud app was installed and I could open it.

Hopefully this is fixed by Microsoft or Apple in a less kluge-y way, of course.

| improve this answer | |
0

Here's my solution. Having researched all of the error messages and taken a deep dive through all of them, it seemed (on my system at least - Windows 7 64 bit) that the problem was due to a lack of the Visual C++ 2015 runtime, which should be installed and which the iCloud installer seems to assume is present.

I ran a complete Windows Update, then manually installed both x86 and x64 versions of the runtime. Rebooted, then tried iCloud again.

Result? Worked first time.

Your mileage may vary of course.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .