1

My Macbook Pro, OSX El Capitan 10.11.1, disconnects from my Windows PC's shared iTunes library whenever it (my Macbook) sleeps.

To reconnect it I have to restart music sharing from the Windows machine.

This is a pain, and I'd like to stay connected all the time.


For those who enjoy reading...

I've turned on music sharing with iTunes on my Windows PC by following these steps:

  1. opening preferences (Edit > Preferences)
  2. Going to the sharing section
  3. Checking the box "Share my library on my local network"
  4. Checking the box "Home Sharing computers and devices update play counts"

which I got from here. At the end of the process I follow, my preferences screen looks identical to the one shown in the article.

Then, when I open iTunes on my Macbook Pro Retina, 15", OSX El Capitan 10.11.1,

My device specifics

I can see my Windows Computer's iTunes library and access it and play songs from it.

However, when my macbook falls asleep, it seems to somehow disconnect from the Windows machine, and I can no longer access the remote library.

I have to restart music sharing from my Windows machine in order for my macbook to reconnect.

How can I keep my Macbook connected?

  • Force it to always stay awake? – Joonas Nov 26 '15 at 9:49
1

Try the following. On your Mac, click System Preferences > Security&Privacy > Firewall > Advanced > Deselect Log out after xx minutes of activity. This will stop iTunes switching off even though your Mac is in sleep mode. If the number of minutes in the prior selection equals the time at which the connection is lost, this is probably your problem.

0

This is not a complete answer, and I will update it once I have a Mac in front of me, but basically you will need to take a good hard look into your System Preferences, specifically the Energy Saver options.

There should be an option in there called Wake for Network Access, and it may help to check this box, however, I think that mostly has to do with accepting a "magic packet" for WOL (Wake-On-LAN) access -- but I could be wrong, and it could solve your issue immediately. Not quite sure on that specific option, but...

There are a few other things you can do in order to prevent this type of behavior:

You can edit your power preferences so that your computer never sleeps, however, this will obviously decrease your battery drastically if you are not connected to power.

You should also be able to create a custom power profile (I'm sure it's available is OS X, although I have personally never created one like I have in Windows)

Download a third party application to run only while you need this functionality available -- which is keeping your computer awake -- the root cause of your issue is that whenever you computer goes to sleep, WiFi access is automatically turned off until the computer is woken up.

The third party apps that I know of are called InsomniaX and Caffeine. I used to use InsomniaX with Snow Leopard, and it worked great. Caffeine is available in the Mac AppStore or the developer's website, which I linked in the name, and I think InsomniaX is available in the HackStore or from the developer's website, which I also linked in the name.

That being said, the best solution, IMHO, would be to double-check your Energy Saver options, and then whenever you want this functionality available to your other computers, just hook your MBP up to power and Ethernet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .