Safari has started display scrambled text on some websites. This only happens on certain site and in Safari. I've also noticed that the problem may appear in certain spots on the website, like the header, or an ad on Facebook.

Here's a screenshot of oDesk.com in Safari 5.1 (7534.48.3)

enter image description here

And here's a comparison in Chrome (13.0.782.112)

enter image description here

The problem only cropped up today but it's really frustrating as Safari is my main browser. I've tried deleting the Preferences file but that didn't solve the problem. Any help would be appreciated. Thanks.

5 Answers 5


Fixed-width text not appearing correctly in Safari after Lion upgrade

This is a known bug. Check the link above and see if my instructions fix it for you.


The what is easy - safari can't find the exact font or a close substitute. Chrome either includes that font or has a different default font or slightly different substitution path.

The why can be much more individual or nuanced.

Some likely causes will have you using Font Book.

  • The font Safari chose to substitute is disabled.
  • If the font database has issues - the substitution process isn't as robust until it's rebuilt (you can test this by booting in safe mode).
  • If the font itself is corrupt - it needs to be reinstalled.
  • If a bug results in strict interpretation - substitution doesn't happen.

Since each OS (Lion, Snow Leopard, and older) is a little different - the best bet is to open font book and validate your fonts. Pay attention to any fonts that might be disabled as well.

The built-in help menu will have "troubleshooting" steps that eventually have you call AppleCare since a hardware / hard drive could be the root cause once you've cleaned up the fonts and made sure it's not just a duplicate or font database issue.


You seem to be reporting a similar (but not identical) problem to the one I'm encountering here. Wish I had an answer.


From Apple Support Communities:

Restart in safe mode than normal boot. If that doesn't do the trick, run Font Book and validate all fonts.


I had the same problem.

I simply copied one of the display characters ("A")from the webpage and pasted it in to "simple text" and right click to show font. I saw it was "ARIAL" then went to Font Book and fixed that font (Arial.) That's it, problem solved!

I hope this works for you

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .