7

I've never see this before.

enter image description here

Here's the facts:

  • It appears to be grayed out in the finder
  • I can not open it by clicking
  • I can move the folder
  • The permissions are set to 777 (overkill i know)
  • I can rename the folder with the mv command
  • I can view the contents of the folder with ls
  • When I ls (list) the contents of the parent dir I can see it without -a (show hidden files)
  • The date is set to from before I was born.
  • I believe this folder to have been a copy of another

I have a folder and I can't open it. It appears to be grayed out in the finder.

  • All files/folders show Jan24 1984 when copying & until the copy is complete. It's a reference to the date of Steve Jobs' announcement of the first Mac. – Tetsujin Nov 18 '15 at 11:47
  • If you answered your own question please mark it as the accepted answer. – ʀ2ᴅ2 Nov 27 '18 at 15:16
10

I had the same issue with an account folder, which I restored from a backup via rsync. The problem seemed to be the corrupt or missing creation date. After setting it manually the folder was acting normal again. I used the SetFile command from XCode's command line tools. So this should solve the issue:

SetFile -d '12/31/1999 23:59:59' will-not-open
1

This works:

mkdir move
mv will-not-open/* move/
rm -rf will-not-open/
mv move will-not-open
1

Using some of the answers above as a guide, I opened a terminal and did the following:

mkdir NewFolder
mv will-not-open/* NewFolder/.

I then deleted the will-not-open folder. The NewFolder opens OK with Finder and I can access all of the files in it with no problem

0

To force opening the problematic folder:

  1. Go to the parent folder, and from the Finder's menu select Go, then Go to Folder....

    Or simply hit CMD-Shift-G.

  2. In the input box which should be shown, type the name of the folder, e.g. will-not-open.

0

Here is the workaround using Terminal app.

  1. Open Terminal app.
  2. Type open and hit Space.
  3. Then drag and drop the problematic folder into Terminal app, to populate the full path.

    At this point, the command should be like: open /full/path/to/will-not-open.

  4. Run the command by hitting Enter.

0

Make sure the folder isn't Locked by clicking on the item (right-click) and checking in Get Info.

Then try to remove will-not-open/.DS_Store file which contains the special folder settings about how Finder sees it.

Here is the Terminal command to do that (run in the parent folder):

find . -name ".DS_Store" -print -delete

You can also check the extended file/folder attributes by running:

mdls will-not-open/

and verify which flags need to be changed or disabled.


If still won't work, try restarting Finder service by these commands:

launchctl stop com.apple.Finder
launchctl start com.apple.Finder
0

Other things can cause this problem. For me it was a full disk, followed by a computer crash.

I was copying an 80 GB folder to a 1000 GB drive that had 610 GB of files and 350 GB in the Trash, leaving only 40 GB free (1000G-610G-350G=40G). The Mac ran out of space on the external drive during Copy, then it crashed and re-booted automatically while I was out of the room. When I logged back on I had a greyed out Folder of size 40 GB that was inaccessible.

I moved it using the procedures outlined above, then deleted it.

Then I Emptied the Trash, which gave me 400 GB of space. And the problem did not recur.

-1

i copy pasted the grayed out folder into a new folder that i made. somehow it worked. i deleted the grayed out folder and used a copy pasted version of it. no Xcode needed

  • somehow it worked is a phrase unlikely to be appreciated by the users on this site. Consider expanding your explanation; we like well thought out and articulated answers. – Allan Jan 10 '18 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .