I've never see this before.

enter image description here

Here's the facts:

  • It appears to be grayed out in the finder
  • I can not open it by clicking
  • I can move the folder
  • The permissions are set to 777 (overkill i know)
  • I can rename the folder with the mv command
  • I can view the contents of the folder with ls
  • When I ls (list) the contents of the parent dir I can see it without -a (show hidden files)
  • The date is set to from before I was born.
  • I believe this folder to have been a copy of another

I have a folder and I can't open it. It appears to be grayed out in the finder.

  • 2
    All files/folders show Jan24 1984 when copying & until the copy is complete. It's a reference to the date of Steve Jobs' announcement of the first Mac.
    – Tetsujin
    Commented Nov 18, 2015 at 11:47

11 Answers 11


I had the same issue with an account folder, which I restored from a backup via rsync. The problem seemed to be the corrupt or missing creation date. After setting it manually the folder was acting normal again. I used the SetFile command from XCode's command line tools. So this should solve the issue:

SetFile -d '12/31/1999 23:59:59' will-not-open
  • This is exactly what I needed. For context, the files in question were from an aborted Finder copy that I otherwise fixed up with rsync.
    – Mattie
    Commented Jan 9 at 15:24

Using some of the answers above as a guide, I opened a terminal and did the following:

mkdir NewFolder
mv will-not-open/* NewFolder/.

I then deleted the will-not-open folder. The NewFolder opens OK with Finder and I can access all of the files in it with no problem


Here is the workaround using Terminal app.

  1. Open Terminal app.

  2. Type open and hit Space.

  3. Then drag and drop the problematic folder into Terminal app, to populate the full path.

    At this point, the command should be like: open /full/path/to/will-not-open.

  4. Run the command by hitting Enter.

  • Safest most straightforward solution. After opening said folder, I copied its content into a new folder and then deleted that weird dimmed folder with wrong created date.
    – Korayem
    Commented May 7, 2021 at 21:14

Super Quick Fix:

  1. Right click on the "grayed out folder" and make an Alias of the folder that is "greyed out"

  2. Click on the alias and you get right in.

  3. Next move the files and folders out of the "Grayed out" folder into a "new folder". Command + drag the contents to the "new folder" (It may ask you for your password to make the move.

  4. Trash the now empty "grayed out" folder and rename the "new folder" to the name the "grayed out" folder used to have... Fixed 🙂

  • This worked for me, but only when choosing "Show Original" in the context menu of the alias.
    – Mischa
    Commented Dec 27, 2020 at 9:56

This works:

mkdir move
mv will-not-open/* move/
rm -rf will-not-open/
mv move will-not-open

To force opening the problematic folder:

  1. Go to the parent folder, and from the Finder's menu select Go, then Go to Folder....

    Or simply hit CMD-Shift-G.

  2. In the input box which should be shown, type the name of the folder, e.g. will-not-open.


Make sure the folder isn't Locked by clicking on the item (right-click) and checking in Get Info.

Then try to remove will-not-open/.DS_Store file which contains the special folder settings about how Finder sees it.

Here is the Terminal command to do that (run in the parent folder):

find . -name ".DS_Store" -print -delete

You can also check the extended file/folder attributes by running:

mdls will-not-open/

and verify which flags need to be changed or disabled.

If still won't work, try restarting Finder service by these commands:

launchctl stop com.apple.Finder
launchctl start com.apple.Finder

Other things can cause this problem. For me it was a full disk, followed by a computer crash.

I was copying an 80 GB folder to a 1000 GB drive that had 610 GB of files and 350 GB in the Trash, leaving only 40 GB free (1000G-610G-350G=40G). The Mac ran out of space on the external drive during Copy, then it crashed and re-booted automatically while I was out of the room. When I logged back on I had a greyed out Folder of size 40 GB that was inaccessible.

I moved it using the procedures outlined above, then deleted it.

Then I Emptied the Trash, which gave me 400 GB of space. And the problem did not recur.


Perhaps an issue copying the folder from one source to another that corrupted some metadata.

The easiest way:

  1. Right on the grayed folder and select the option Duplicate.
  2. In the new duplicated folder you will have all the files.
  3. Now you can delete the grayed folder.
  4. Finally, rename the duplicated folder to whatever you want.

Best fix for "grayed out folder won't open in finder":

# set creation date to modified date:
sudo /usr/bin/SetFile -d "$(GetFileInfo -m "$D")" "$D" 

It happens mostly if a Finder File/Folder Copy was not finished.


i copy pasted the grayed out folder into a new folder that i made. somehow it worked. i deleted the grayed out folder and used a copy pasted version of it. no Xcode needed

  • somehow it worked is a phrase unlikely to be appreciated by the users on this site. Consider expanding your explanation; we like well thought out and articulated answers.
    – Allan
    Commented Jan 10, 2018 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .