Some of the apps on my MacBook Air (OS El Capitan) specifically my Grand Theft Auto are not opening because a prompt appears "Verifying (Name Of The App)". I've tried countless times to fix this but nothing has worked. Any suggestions on how might I fix this?

  • How did you try and fix it? – At0mic Nov 18 '15 at 16:01
  • I went into settings and allowed apps downloaded from anywhere. – Mike Johnston Nov 19 '15 at 2:20
  • does OS X get anywhere with the verification? – At0mic Nov 19 '15 at 14:02
  • No, the progress bar gets to the end and the window just closes. – Mike Johnston Nov 24 '15 at 1:14

If you are sure that you downloaded the app installer from the official/verified source and that it has not been tempered with, you can skip the verification process altogether by removing the extended file attribute that causes FileVault to attempt to verify the application. Do this by executing the following command from terminal:

xattr -d com.apple.quarantine /Applications/app_name.app

The app_name.app is the name of the application you are changing the extended attributes on. In this case, GTA5.app.

The xattr command allows you to view and change extended file attributes. The -d flag indicates you are deleting the com.apple.quarantine attribute which is set on the application package. Any file with the extended attribute of com.apple.quarantine is verified by FileVault. This attribute is typically automatically set on downloaded files and files extracted from a tar or zip archive.

  • Some context for this would be helpful - can you write a bit about what this command accomplishes? – Scot Jan 27 '18 at 23:03
  • 1
    incredible that this doesn't require administrator privileges. – I'm_With_Stupid Aug 22 '19 at 2:10
  • I just want to clarify that to check if the com.apple.quarantine attribute is present, you should type "xattr /Applications/app_name.app" – David Killingsworth Aug 22 '19 at 7:25
  • @I'm_With_Stupid It actually does require sudo. So the command above would be "sudo xattr -d com.apple.quarantine /Applications/app_name.app" and then you would need to enter the admin password for the command to work. – David Killingsworth Aug 22 '19 at 7:45

This verification ensures that the application is not tampered with, so I would consider re-downloading and re-installing any app that fails to verify.

If you have an installer package and you're sure it validates by checking the checksum or you have a backup and no data that would be sensitive if it's compromised - you can force the installer to run:

But - again, you are disabling a safety feature, so I would back up your machine and data in case there's something going on with the safety system.


EDIT: It seems I had some fw rules on my router that blocked access to some apple servers (I set them up to run some tests a while ago). After removing the rules, all is well.

Just disable your network connection temporarily. I believe somethings's wrong with Apple's way to query their servers for potentially malicious software definitions.

  • This worked for me. I pulled my network plug and then put it back and it resolved. – Haru Sep 17 '19 at 20:39

I had this problem many times lately (Mac OS quality degrading)... Here is a workaround:

  1. Open /System/Library/CoreServices/Installer.app
  2. navigate to the installer that is stuck, and install it
  • This is for a disk image, not an app. – user3932000 May 22 '18 at 4:24

Well I had the exact same problem with it on my mac book air. I kept opening it and it would keep saying "verifying "GTA 5". When I went go to the bathroom it opened by it's self. I'm pretty sure this is dew to the large file sizes and it taking longer to work, as minecraft and league of legends verified almost instantly. I suggest Waiting up to 5min and come back see if it is still verifying and it might be done. I hope this helped you when downloading GTA.


This seems to be the answer:


Hope that helps!

  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the link you provided will answer the question. Links can change and become outdated so we prefer the answers to not just be a link. See How to Answer on how to provide a quality answer. – fsb Sep 22 '16 at 16:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .