2

After a few weeks of using El Capitan seemingly random messages started appearing blank. Viewing the messages in the Google web interface showed that they were not blank.

Restarting the app usually fixes it.

I deleted all my emails (by deleting mail folder ~/Library/Mail) and started again - and it was OK for about a week - and now it's started doing it again. Rebuilding mailboxes doesn't help.

I found links around the web to cases of this back in 2010/2011 - like this https://discussions.apple.com/thread/2364054

But it appeared to go unsolved.

Is this just a bug in El Capitan - and is there a solution?

  • see apple.stackexchange.com/a/174732/85275 to rebuild and reindex – Tetsujin Nov 24 '15 at 11:05
  • Did you find a decent solution yet? I'm having exactly the same problem you described. – Tuslareb Dec 11 '15 at 17:35
  • It hasn't done it for a while. If it happens - I just close mail & reopen and it's fine. There was a big OS update (10.11.2) a couple of days ago, it had a lot of bug fixes (not many details released though) - it hasn't happened since installing that, hopefully it fixed it?! – niico Dec 12 '15 at 23:00
  • happened again yesterday - just closed & reopened. THS IS STILL A BUG APPLE. – niico Dec 15 '15 at 17:42
1

To fix this issue there are two ways:

  1. Rebuild

To rebuild a Mailbox in Mail, select the mailbox you want to rebuild and click on the Mailbox menu; at the bottom there is the Rebuild option. Repeat this step for each one of your Mailboxes.

It can take few hours to reindex a large mailbox and if it's an IMAP or Exchange mailbox, the rebuild will have to download again everything from the server.

  1. Reindex

It is also often necessary to manually reindex Mail messages after a major OS upgrade. This is also necessary if Mail becomes unresponsive and/or if search is not functioning correctly or the app doesn't run.

  1. Quit Mail if it’s open.

  2. From the terminal run

    mkdir ~/Desktop/backup
    mv ~/Library/Mail/V2/MailData/Envelope\ Index*  ~/Desktop/backup`
    

    (replace V2 with V4 for Sierra).

  3. Launch Mail and it will build new Envelope Index files; that can take a long time if there are many messages to reindex and if it's an IMAP or Exchange mailbox, the rebuild will have to download again everything from the server.

If everything seems to be working correctly, you can now delete the backup from from your desktop (rm ~/Desktop/backup).

  • I clearly stated rebuilding doesn't help. – niico Oct 2 '16 at 19:46
  • It's a good habit to do both in that order, that's why I reported both. – David Oct 2 '16 at 19:48
0

Most mail issues can be reduced to a specific fault with a little troubleshooting.

Open the connection doctor window in Mail.app and see if you can determine one specific mail host with issues.

Then set up a new user account with only that mail account and enable logging. At that point, you will know if you have a networking issue, a problem with one computer or a problem with one mail provider and your specific mail client.

Then you can decide to work with support for that mail provider, document the failure here with specific error messages and/or determine that you have a temporary issue that clears up over time due to capacity or temporary networking issues / delays / one host.

0

I have this problem infrequently. Quitting and restarting mail.app fixes it and just takes a second. Another quick and dirty solution is to click on email forward which will let you see the email contents right away.

  • I like Mike Perlmans solution above which is to click on email forward. Works every time but why I have no idea. Alternative is to log onto your email account via Safari and body of email appears as normal there as well. – keith Mar 4 '17 at 14:07
0

This is an old question but I landed here from a search; one thing that works for me sometimes when other solutions listed here don't is to move the email in question to a different account. The contents usually become visible immediately. You can then move it back (if you want to) and it will remain visible.

-1

You could try to delete the whole Mail folder here: ~/Library/Mail

and delete the mail preferences files in

~/Library/Preferences

Then reconfigure the Mail. This will of course delete emails which are only saved locally. Instead of deleting you could of course close the app and move the files to another location for backup.

I've seen the same issue happening. The problem occured after switching the mail server. I had tried everything I could think of like rebuilding the mail box, deleteting the mailbox indexes, renaming mail boxes, force re-downloading the emails, re-adding the email account. The only thing that worked was deleting what i mentioned above.

  • Already did the former when I deleted all messages, not sure about latter? – niico Nov 22 '15 at 11:00
  • a bit heavy-handed. Nuke & pave rather than find & fix the issue. – Tetsujin Nov 24 '15 at 11:05
  • One of my customers had the same issue. The only thing that worked was what I mentioned above. It's sometimes not enough to just delete the Mail directory. @Tetsujin you're free to offer a better solution. I'm sure you have one since you complain about the one given above. – B. Martin Nov 24 '15 at 11:08
  • So if I delete the Preferences folder - will I have to setup all my accounts again? What is lost? Also - how long has it been working since the 'fix'? – niico Nov 25 '15 at 11:52
  • Don't delete the whole folder only the mail preferences files. So open the folder and search for the files related to Apple Mail. It has been working since the beginning of october. I'm not exactly sure what was stores in the preferences files. I did a full reset of Mail. That's what worked for my customer. – B. Martin Nov 25 '15 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .