For my own purposes, I created service named "Launch Terminal" which, naturally, launches terminal. I've edited it few times, then renamed, moved to iCloud, then again edited and finally copied to a local machine. Now here's a problem:

Shortcut for this service is Command-Control-T. If a shortcut is set to this, then in Finder and Terminal applications, the shortcut doesn't work, while it works elsewhere. Moreover, when I open services menu in these two apps, I see entry "Launch Terminal" and it works only if clicked. No symbols, denoting key combination of shortcut are displayed in this menu, only the name of the service. The problem disappears if I set another key combination for this service or if I rename it. I tried rebooting several times and I tried rebuilding LaunchServices database with

sudo /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Command-Control-T is used to add files/folders to Favorites Sidebar in Finder. May be you should try some other shortcut.

  • Why then it works everywhere except Terminal? – assp1r1n3 Nov 17 '15 at 20:43
  • Well, in terminal this combination corresponds to opening a new tab with the same command. Thanks for helping to figure it out! – assp1r1n3 Nov 17 '15 at 20:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .