4

My media keys had stopped working in iTunes on my Macbook Pro. They were working fine in VLC. I tried checking for the usual suspects:

  • iTunes preferences
  • Google Chrome Play music extension

Neither of them was the case for me.

I created a new user account on my Mac and the media keys worked fine on that one. So I tried copying the com.apple.itunes files from the Library of that account into the main account. This didn't help neither. What should I do?

12

Finally, I ran the following 2 commands in my terminal:

launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist
launchctl load -w /System/Library/LaunchAgents/com.apple.rcd.plist

Worked like a charm!

2
  • It didn't work for me somehow, macOS Sierra v10.12.2 on Macbook Air. does this require a system restart? – computingfreak Feb 4 '17 at 13:17
  • this was already quite easy to find: superuser.com/a/827710/28411 – cregox May 12 '17 at 1:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .