7

I'm sure this has been asked before, but I can't seem to search for the right terms. I have a playlist in iTunes that has over 200 songs in it, yet when on Shuffle, iTunes plays the same 15-20 songs over and over. I created the playlist over a year ago and listen at work almost every day, and there are dozens of songs that have never been played unless I turn off shuffle and manually select them to play.

I know Shuffle is random, and that true mathematical randomness means it's just as likely that you'd hear the same song 10 times in a row as that you'd hear 10 different songs, but isn't there some way to force iTunes to play all the songs in a playlist when it's on Shuffle?

I'm currently running iTunes 10.4 on a Mac (Snow Leopard), but this is true on other versions and operating systems as well.

  • I have the same situation with my playlists as well. I say this not because I have a solution but rather because I'm frustrated to the point of apathy. The issue, for me, comes to light when a list is transferred to a Shuffle or iPHone, though. Keeps transferring the same songs more or less and ignores thousands of others regardless of what I do. – user83495 Jun 24 '14 at 16:24
  • Is there anything you can add to this? Is it reproducible on a newer version of iTunes or newer device? Did you solve it perhaps? – bmike Jun 24 '14 at 16:52
  • 1
    Btw, about randomness: If, after each song, iTunes randomly selected a song from the list, then hearing 10 different songs is much more likely than hearing the same song 10 times. However, if you specify a particular list of 10 different songs, then the probability of hearing that particular list of songs in order is equal to the probability of hearing 10 songs in a row. I don't think that's the method that iTunes uses, though. Based on answers to this question and others, it may be that when you choose shuffle, iTunes picks a random list of songs in which each song appears only once. – Mars Feb 23 '16 at 3:29
4

iTunes defines the random order of the tracks when you first specify set "Shuffle". (This is so that the skip forward / backward buttons work in a reasonable manner.) If you never turn Shuffle on or off, that order is never changed. Just disable and then re-enable Shuffle to get a new random order of tracks.

For more detail, see Why isn't iTunes shuffle random?.

  • Well, that's a nice theory, but all of the songs I put in the playlist have been there since the beginning. There are no new songs. So shouldn't it have set a random order including ALL of the songs that existed at the time Shuffle was first turned on? – EmmyS Mar 26 '12 at 14:26
  • Hm, yes, it should have. Maybe this playlist was corrupted somehow when it was created? Have you tried creating a new playlist with those songs? Also, do all of the songs have the checkbox checked? – KatieK Mar 26 '12 at 17:15
  • Do you always start with the same song? Perhaps that song is the 10th-last in the order. Try hitting play with no track selected so it starts at track 1 of the shuffle order. – Kevin Grabher Jun 24 '14 at 16:59
1

The only success I've had replicating this behavior is when I've unchecked some of the songs in a standard playlist. When I do this and play with shuffle turned on only the checked songs play. Perhaps this is your issue.

If you don't see any checkboxes on the left go to Preferences | General and check the box that says Show list checkboxes.

  • Nope, that's not the issue. All songs are checked. – EmmyS Apr 23 '12 at 18:01
  • Hmm. So it's a non-smart playlist, all songs are checked, you've toggled the shuffle on/off, resorted the list by using the arrow column, and it's still not working? I'm stumped. – John Rygielski Apr 24 '12 at 12:32
1

Hey I have faced the same problem, and I did not get the correct answer. But after some hit n trail I got the solution:

Right Click on playlist from left panel >> select Add to Up Next option. Enjoy

1

My solution to 'not playing all songs in a playlist (in my case, not doing continuous play one song after another; or in 'shuffle') was quick and embarrassingly easy - the shaded box in front of songs' titles did not have a check mark. Mystery as to how the check marks had disappeared?!? I did not notice this right off so I wasted time trying different things. So, I suggest step 1, make sure the boxes are checked.

0

Did you try going into the song properties (right-click song choose "Get Info") and from he "Options" tab de-select the tick that is in "Skip When Shuffling"?

0

Select all songs in playlist.(click on 1st song, hold shift key and click on last song) Right click. click on "Check Selection" All songs will be selected and they will all play.

0

Itunes is really annoying on this point, the workaround is fairly easy though, shuffle the tracks until they look like an order you are happy with, then click on a track and select all (cmd A). Right click and click play next, iTunes will then play every track in the order shown on your screen. If there are lots of tracks in your list that iTunes never play, click at the top of the column headed 'plays' and the list will be reordered so that you can then scroll to the part of the list with no play and select just those tracks, right click and 'play next', you can then listen to all the tracks that iTunes refuses to play! :) Now I have given you all that information iTunes will probably change the programme again so that you won't get all your tracks :( Good luck music buffs!

0

Under the Play/Pause, FF and Rewind buttons, there is a Shuffle button and a Repeat button. Make sure the Repeat button in Not selected. This worked for me.

-1

Right click on the song. Click "Check Selection". :) Worked for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .