6

My Mac Mini, running El Capitan, and my iPhone 6 Plus are both on the same WiFi network, however when I select the Mac Mini in the Text Message Forwarding settings, it does not send a code to my Mac Mini.

If Messages is not running on my Mac Mini, then selecting the Mac Mini in the Text Message Forwarding settings on my iPhone will start the program, but no code. I have signed out and back in to iCloud on both devices, and I have rebooted both devices. Nothing seems to work.

In fact, everything was working as it should until around the time I updated to El Capitan.

How can I troubleshoot SMS handoff from a cell phone to OS X?

1

Handoff works over bluetooth primarily, so you don't really need WiFi connectivity. Start by toggling the bluetooth on both devices and see if other handoff / airdrop operations work. That will rule out interference and other issues on the basic connectivity.

You do need to be signed in to the exact same iCloud account on both devices, so checking the clocks of both and signing out and in can often verify iCloud account is operational on both sides.

| improve this answer | |
  • I can't toggle bluetooth off on my Mac, as I will loose the keyboard and mouse, so I have no way to toggle it back on. I did toggle it off and on on my iPhone though. Again, when I go into "Text Message Forwarding" on my iPhone and select my Mac, it causes the Messages program on my Mac to launch, but still no code. – Flyboy_2 Nov 17 '15 at 23:43
  • @Flyboy_2 If you don't have an alternate mouse, you're right about delaying the mac bluetooth troubleshooting step. The iPhone will forward SMS messages to both Mac, other iPad and Apple Watch - so it should work but it's hard to guess what's messed up without trying things. Does it happen when the Mac restarts? That would cycle the bluetooth as well. – bmike Nov 18 '15 at 2:17
  • I am thinking it must have something to do with the upgrade from Yosemite to El Capitan. Text Message Forwarding used to work just fine on both my Mac Mini, and my MacBook Air. Neither one works now. I cycled bluetooth on my iPhone and my MacBook Air. It does the same as the Mac Mini. When I select the MacBook Air in Text Message Forwarding on my iPhone, it will launch the Messages program, but it does NOT send any code. – Flyboy_2 Nov 20 '15 at 0:12
0

Saw on reddit you have to make sure in preferences of messages that you are on the same Apple ID as on your phone, some times for what ever reason they can be different than the account on the computer.

All that was correct for me, simply logging out in message preferences and logging back in fixed the issue for me.

| improve this answer | |
0

This just happened to me the other day, not initiated by anything I did. It started with my iPhone “acting” weird (smartphones be acting stupid!) telling me that No SIM was installed, which was bullcrap (in my experience, phones start “acting” this way at the 1.5 to 2 year mark... Hmm I wonder why?? Planned Obsolescence perhaps???).

Anyway, when I saw that message, I restarted my iPhone, and it was functional. However, I didn’t notice until later that my iPad could no longer send or receive my SMS messages (iMessage was fine).

I did some basic troubleshooting. I went to Settings > Messages > Text Message Forwarding

  • Disabled and reenabled the iPad (and got no Forwarding code on the iPad)
  • Turned off/on iMessage on iPad
  • Rebooted iPhone and iPad throughout all this in many different combinations (while sometimes leaving things off before restarting, and reenabling them after reboot, etc.)

None of that worked.

Today, I searched online for an answer again, and it led me to this post, for which I’m grateful, because it led me to investigate my settings once more, and I stumbled upon the problem and this is what fixed it for me!

Settings > Messages > Send & Receive

I don’t remember what the settings were on my iPad before this “broke” a couple of days ago, but when I got into my iPad settings, I could see that my phone number was not set to “Start New Conversations” which made me think that was the problem, so I compared the settings to my iPhone and ensured that my iPad was matching the iPhone settings. I specifically have both set to “Start New Conversations” with my phone number, and I think that’s what did it!

Note that this fixed things right away, no need to reenable or resend codes or anything.

I hope that helps someone!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .