2

For some reason my mac mini refuses to start the screensaver or go to sleep unless I put the mouse into a hot corner. Energy saver is set to 3 mins as is system sleep. Any ideas would be greatly appreciated. i have included a PMSET -G result but don't really understand it. Many thanks. (Mac Mini, 2.5Ghz intel, 4GB RAM, 10.7.5)

AC Power        -1*
Currently in use:
hibernatemode   0
disksleep   10
womp        1
networkoversleep    0
sleep       5
powerbutton 1
ttyskeepawake   1
hibernatefile   /var/vm/sleepimage
autorestart 0
panicrestart    157680000
displaysleep    3 (imposed by 181)
4
  • could it be that your mouse sends a 'moving' signal to your machine? Have you unplugged your keyboard and mouse and tried to wait for 3 min? – CousinCocaine Nov 16 '15 at 20:55
  • Have you tried to use another user account? – CousinCocaine Nov 16 '15 at 20:55
  • What's a "hot corner"? (Literally a corner of the room that is hot?!) – MrWhite Nov 16 '15 at 22:38
  • 1
    @w3d In the system preferences, you can specify actions when the cursor enters any of the 4 screen corners. I have my display sleep/off when the cursor is in the lower left corner for instance. – bmike Nov 16 '15 at 22:40
1

To debug this, you'll need to open terminal.app and look at the power assertions log. It's pretty verbose, but it really shows what's going on to prevent a sleep from happening.

pmset -g assertionslog

If you need a smaller set of data to look at, just ask for the current status and not an ongoing log of what's set and what's changing.

pmset -g assertions

You can close the window when you're done with the tools.

3
  • Thanks. i did a pmset -g assertions and spotted this. -------- Listed by owning process: pid 181: [0x000000b5012c0009] PreventUserIdleDisplaySleep named: "extension" code-------- Any idea how to got about deleting/editing this 'extension' what ever it is? Many thanks. – joachim Nov 17 '15 at 19:45
  • @joachim You could use Activity Monitor to look at that PID (process identifier number) - without knowing what it was and if it's still holding sleep 5 minutes later, it's hard to say what to do next. Be sure to show all processes in the monitor. – bmike Nov 17 '15 at 22:15
  • 1
    That all worked great. Discovered an extension that was keeing it awake. Thanks. – joachim Nov 19 '15 at 7:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .