0

After upgrading to the newest El Capitan from 10.10. to 10.11.1 - I guess - the normally invisible EFI partition appears on the desktop as a regular volume on different machines, if I choose to show the volumes in the finder preferences.

When I start "First Aid" with Disk utility the EFI partition get ejected, but on the next start they will appear again. I can boot in Recovery Mode and El Capitan seems to work fine (as fine as it can).

But how can I get OS X not to autoload the EFI partition and hide it again?

visible volumes desktop

Admins Mac Pro:~ admin$ diskutil info /Volumes/EFI
Device Identifier: disk0s1
Device Node: /dev/disk0s1
Whole: No
Part of Whole: disk0
Device / Media Name: EFI System Partition
Volume Name: EFI
Mounted: Yes
Mount Point: /Volumes/EFI
File System Personality: MS-DOS FAT32
Type (Bundle): msdos
Name (User Visible): MS-DOS (FAT32)
Partition Type: EFI
OS Can Be Installed: No
Media Type: Generic
Protocol: SATA
SMART Status: Verified
Volume UUID: 0E239BC6-F960-3107-89CF-1C97F78BB46B
Disk / Partition UUID: BF3A02F5-1B7F-4F5C-9E27-2C3378181F53
Total Size: 209.7 MB (209715200 Bytes) (exactly 409600 512-Byte-Units)
Volume Free Space: 181.5 MB (181542912 Bytes) (exactly 354576 512-Byte-Units)
Device Block Size: 512 Bytes
Allocation Block Size: 512 Bytes
Read-Only Media: No
Read-Only Volume: No
Device Location: Internal
Removable Media: No
Solid State: No

1

Since El Capitan this is the behavior of Workgroupmanager for local accounts if you enable to manage internal harddrives to be only readable for some users. It doesn't matter which user logs in. If there is only one user managed, the EFI partition will show up on start for all useres. Disabling this in Workgroupmanager again hides the EFI partition, too. Since Workgroupmanager was lastly updated on Mavericks it is still possible to manage e.g. USB shares to be only readable without having to install a OSX Server, as there is no on board solution for managing user accounts more differentiated than with System preferences.

  • Actually this helped me, even it is my own answer... – Hirschferkel Nov 30 '15 at 9:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .