0

OSX 10.10.3, also reproducible on 10.8, doesn't seem to happen on 10.11

Reproduction steps

  1. Go to System preferences > Audio > Input
  2. Set input volume to 0 (this is important)
  3. Run this script in Terminal

    sudo osascript -e "set volume input volume 100"
    
  4. This script should set mic to max volume and un-mute it accordingly, but for Mac OS < 10.11, the microphone stays muted, despite of the fact that the input volume bar is now set to maximum.

Edition 2

The following AppleScript works:

tell application "System Events"
    set volume input volume 100
end tell

tell application "System Preferences"
    set current pane to pane id "com.apple.preference.sound"
end tell

tell application "System Events"
    tell process "System Preferences"
       set visible to false
       click radio button "input" of tab group 1 of window "Sound"
       perform action "AXIncrement" of slider 1 of group 2 of tab group 1 of window "Sound"
    end tell
end tell

tell application "System Preferences"
    quit
end tell

But unfortunately it cannot be executed without a permission from user to Accessibility (that requires relatively difficult actions from user).

Edition 3

Tried to kill coreaudiod, VDCAssistant. Kext unload/load is very dangerous and not reliable, shouldn't be considered.

Need help

  • Can you reproduce it in OSX < 10.11?
  • Is there any other way to fix this bug? Terminal commands? Triggering some apps? Killing some processes? Modifying some plists? Anything else?
  • Why is it a bug - I don't want programs turning my mic on without explicitly choosing to – Mark Nov 16 '15 at 14:16
  • Skype does it somehow. When you start a call you "give your permission" to turn your microphone... because you start a call! I mean sometimes it makes sense. And it is a bug, because the script works in 10.11. I don't even mind to ask a user a computer password if needed. – igorpavlov Nov 16 '15 at 14:20
  • set volume without output muted - set volume with output muted – StrawHara Nov 16 '15 at 14:42
  • Is it about output volume, not input volume? – igorpavlov Nov 16 '15 at 14:43
  • It's probably the same syntax with input, isn't it ? – StrawHara Nov 16 '15 at 14:46

You must log in to answer this question.

Browse other questions tagged .