0

I have just purchased a new Asustor 7004T network attached storage device, which I had hoped to use as an archive for the massive quantity of files I have spread across multiple computers and external hard drives. The problem is, I have many of these files meticulously organized by "date created", and recently learned, to my utter disbelief, that my device (and apparently NASes in general) does not preserve the creation date of any file transferred to it. For example, if I take three files dated 9/24/2008, 7/31/2011, and 1/6/2014, and simultaneously migrate them over to the NAS on 11/15/2015, they all end up with the timestamp of 11/15/2015. This is nothing short of a disaster for me, and I am flabbergasted (and frankly outraged) that a top-of-the-line, $1,000+ device expressly made for storing and backing up files was designed without a data storage capability possessed by any $5 2GB flash drive.

I am desperate for a way to circumvent this fatal (for me) flaw of the Asustor NAS. I would be eternally grateful to anyone who could recommend a means of copying files to an NAS that leaves the creation date intact, without potentially corrupting any data or otherwise compromising the security of my files.

Some key information: my computer is a 2012 MacBook Pro running Mac OS X 10.9.5. I am a 1988 model human being compatible with most Web Browsers and proficient with a handful of basic applications such as Microsoft Word, with the capacity to comprehend and follow simple step-by-step instructions as far as more technical tasks are concerned. In other words, if your solution is any more complex than downloading and installing an app, you should probably take a "for dummies" approach in explaining it to me. I would also appreciate any input from users of a particular method who found it to be buggy, ineffective, or otherwise problematic, for Murphy's Law is an ever-present specter in my life, and I would thank you to inform me of all the pros and cons of a particular solution before I risk implementing it.

Thank you in advance to all who contribute their help. I have not been able to find any other sites or forums where someone has asked about this issue in regard to a Mac or Asustor device, and hope that this thread will prove helpful to other users of those systems who share my predicament (I cannot imagine I am the only one).

  • You should provide the info requested by J.C. but be aware that Unix/Linux does NOT normally store Creation Date but inode Change Time. (OS X does actually store this as a 4th time field but the actual storage location and method of access are cryptic.) Windows does store Creation Time (even on FAT32), but this is application specific. Sometimes this is changed when moving/copying to a different partition as this is regarded as a "creation" event. – Milliways Nov 15 '15 at 11:36
1

The Problem lies not in your Asustor per se but in the file system (and subsequently the drive configuration) you use and the copy routine you use. In a nutshell: There are different methods to copy files (f.e. rsync) and different ways the file systems store data (f.e. creation date).

Without further Information regarding your NAS-Setup, File system (necessary) and RAID Level (not necessary, just to be complete), the possible solution at this point would be very general: One possibility would be to use rsync to transfer files from you Mac to the NAS - it should copy all data including creation date. It is a command line tool but there is Software with a GUI which should be more to your likeing. I suggest 'Carbon Copy Cloner', a commercial software but with a 30 day trial.

You should start with that and test it with a few files. If it does not work you should provide more information about the file systems used in the NAS and your external drives.

  • Thank you for your suggestions. Unfortunately, I have tried using both Carbon Copy Cloner and the rsync -a command, and neither of them preserved the timestamp. Also, please understand that I know NEXT TO NOTHING about the intricacies of computers. I'm completely in the dark about file systems and copy routines, or which ones my NAS uses. I'm trying to figure it out, but it's like learning a new language. On that note, here is some information I cribbed from my NAS's server page: (under System Information) ADM Version: 2.5.1.RB62, BIOS Version: 0.25 (under Storage Manager) Raid Level: Single – Bryan B. Nov 17 '15 at 3:56
  • It would have been useful to know what you tried beforehand :-/ I recommend you read about Filesystems (f.e. in Wikipedia) and their capabilities for storing Data and Metadata. IMO it is a necessary requirement before researching about copying and transferring files (which you do have to do next). Also it is vital that you determine the Filesystem of your NAS before trying to copy your data (your comment does not provide a useful answer) with all Metadata bc. it depends on the Filesystem Capabilities and the copy method used. – J.C. Nov 17 '15 at 10:14
  • As an unrelated comment: Check up on the RAID levels your NAS Supports. "Single" as you mentioned probably means all drives are used as single drives. You probably have not experienced a Dive Failure yet - i suggest you should look into RAID 5 or 6. – J.C. Nov 17 '15 at 10:16
  • As another unrelated comment & question: Perhaps the timing is right to adapt your filing system or use a third-party Software to organize (and/or index it) like "NeoDrive". My Question: How did you "meticulously organized" your files by their creation Date? The creation date is generated automatically (which is your current Problem) and usually cannot be changed. – J.C. Nov 17 '15 at 10:22
  • Major update on this issue. Having told me that there was no way for my NAS to remember file creation dates, the Asustor support technician who had been helping me found out that the rules were different for Macs, and (to my enormous relief) it turns out that my NAS does preserve file metadata. – Bryan B. Nov 22 '15 at 5:52
-1

There is a difference between a Copy-N-Paste and Moving a file from a computer to a NAS. Copying from a computer to a NAS will preserve the files original metadata, including the creation time and date stamp; the time and date modified, will of course, represent when the file was copied or transferred to the NAS device. The user should be able to use the sort function within Finder (Mac) or File Explorer (Windows) to organize files by Creation date/time. Moving a file, however, saves the file as a new entity with a creation time/date reflecting when the file was moved. Moving files to a different location is inherently risky, a lost connection during a move or Cut-N-Paste may result in data loss at both the source and destination.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .