0

On my macbook, I successfully set up iCloud and can view all my contacts and such in the Contacts app.

On my iPhone6, I went into settings -> Text Messaging Forwarding and turned on the indicator for my macbook pro. Then my iPhone6 asks me for a code "shown on your Mac". But no code is showing up on my mac?

What now?

1

The iPhone and the macbook should be on the same wifi network.

  • Open the messages app in your macbook, then go to preferences. Click on iMessage account and you should see your iCloud account, check the box near email and phone number
  • go to your iPhone settings -> messages -> Send and receive, and see if your email is there.
  • turn on text message as you did before, the code will show on your messages app on the macbook
2
  • All better! I'm guessing the crucial part of this for me was putting both devices on the same wifi network. Who knew!
    – zkurtz
    Nov 13 '15 at 17:29
  • Happy to help :)
    – enzo
    Nov 13 '15 at 17:30
0

I just got this problem coming with my Mac on Sierra and my iPhone on iOS 10.

I ve deleted the text forwarding message toggle accidently and couldn't receive anymore any text into the MacBook Pro.

The solution for me was to logout of the iMessage icloud account under settings > message > Send and receive > Click on the Apple ID > sign out.

Sign in with another Apple ID into the message section > send and receive > sign in > activated

Go to the Mac and sign out of iMessage going to messages > option top left corner > Apple ID sign out > sign in with the secondary Apple ID >

The Mac will receive the code and will be associated whenever you change the Apple ID since this feature is related to text message and your phone number actually havent changed.

So now you just want to disconnect again from the iPhone first and then connect again >go to the Mac and do the same >

Then you'll have the message iMessage is now used on your new iPhone or Mac

close the settings app on the iPhone

Then you should be able to send text messages again

I hope I ve been clear enough

Cheers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .