1

textbox

This text box appears when I'm using a different input source than English, and quick search in any file list. So when I press A it should point to the file start with a, but instead it display a text box with preedit text.

The box is really annoying and sometime it doesn't disappear, doesn't accept any key press, and I can't even close it.

4
  • Please give more details. When did you start seeing it? Does it appear to be related to Finder itself or another application? Are you using the default Finder or BetterFinder or something of the sort? Are you using QuickSilver or any app like that? Nov 15 '15 at 15:01
  • it appears when I'm using another Input method (in this case Vietnamese/Telex), and then typing in Finder. Any application provides a file list with quick find will display this box
    – ntcong
    Nov 15 '15 at 15:14
  • In my case, using Vietnamese Telex, I get the box, when trying to jump to a file name as you describe. My box however does accept input, and after typing some characters in there, and pressing "return" the box vanishes and the search occurs as expected. A file matching the keys I entered is now selected. -- As for how to disable the box, I can find no obvious setting. Nov 20 '15 at 23:35
  • it does work most of the time, but sometime it just stucks there and I have to find which file list open it in order to close it. And if I closed that file list, then the only way is to reboot
    – ntcong
    Nov 22 '15 at 14:33
1

The box is annoying to be sure. If you are in the Finder and have clicked upon an editable field, or are in a position to type keys that will result int he Quick Search as you have termed it, this box may appear.

If you are using an input keyboard that supports it, this box allows you to type in the "special" characters required by other languages, and use them for your search.

If you leave some characters in this box, and switch to the US input keyboard, this box will be amazingly persistent, yet will be uneditable while in the US Keyboard.

If you want the box to go away, select the appropriate non-US keyboard, delete the contents of the box, and when you switch back to the US keyboard, it will not appear.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .