2

I recently upgraded to El Capitan, and now I am finding I can't install certain software. For example, I needed to view WebEx. WebEx had me download a dmg, but when I clicked it to install, it opened briefly then failed silently.

Then, my Adobe Photoshop and Dreamweaver told me I needed to restore Java 6 (even though I have Java 8 installed and it is backward compatible). I downloaded the correct Java 6 dmg, but again when I tried to install it aborted silently.

I tried launching the dmg from the command line, but that doesn't seem to be recognized as an executable.

FYI, I had selected under security "Allow apps downloaded from Anywhere"

  • 1
    DMG files are disk image files that mount a volume (disk). This volume would normally contain an installer to run or application to copy to your system drive. It could be you're opening the DMG and it is mounting the volume, but you're not seeing it. Are you seeing the mounted volume and it's contents after opening the DMG file? – Mr. Mel Nov 13 '15 at 4:53
  • Yes, thanks, that was the answer. In the past, it would just install the package. Has the behavior changed or did I just never bump into this in the past? (Add this as an answer and I will accept it as correct) – Victor Grazi Nov 13 '15 at 5:04
  • go to Finder > Preferences > General. Make sure 'External Disks' is checked, then you ought to see mounted disk images on the desktop. – Tetsujin Nov 13 '15 at 5:55
  • @Tetsujin I am not seeing that under general. I see things like "Appearance", "Highlight color" scrollbars, etc – Victor Grazi Nov 13 '15 at 14:14
  • Finder Prefs, not System Prefs ;) – Tetsujin Nov 13 '15 at 14:40
1

You are opening a DMG (Disk Image) file that is mounting a volume which contains the installer package to run. To see mounted volumes on the desktop, go to

Finder > Preferences... > General

and check the External Disks checkbox.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .