14

The iMac will not shutdown as normal, the spinning loader is visible and it stays in that state if I don't interrupt it using the power button.

I want to be able to shutdown as normal, at present I'm having to use the power button on the back to interrupt.

I've noticed a few posts on here with the same problem, unfortunately i dont have enough 'reputation points' to comment on their thread. My workflow has stalled to a halt since upgrading to OS X 10.11, El Capitan. Adobe InDesign is terrible and I am really disheartened with Apple for the first time since 1988.

I checked the filesystem with Disk Utility.

  • 1
    What do you want to do exactly? Do you want to shutdown you iMac and you can't? If so, try do the following: Terminal > type 'sudo shutdown -h now' and see if it works. Please edit your question and be more specific. – mgiordi Nov 12 '15 at 10:39
  • 1
    I just want to be able to shutdown as normal, at present im having to use the power button on the back to interrupt, the hints in the title – David Milburn Nov 12 '15 at 11:01
  • So what happens when you click Apple Menu > Shut down? – Arc676 Nov 12 '15 at 11:01
  • 1
    The imac will not shutdown as normal, the loader is visible and it stays in that state if i dont interrupt it using the power button – David Milburn Nov 12 '15 at 11:04
  • 1
    Ive already tried that – David Milburn Nov 12 '15 at 12:22
8

I have found that clearing all cache and font maintenance resolved the issue.

rm -rf ~/Library/Caches/*
rm -rf ~/Library/Saved\ Application\ State/*
sudo rm -rf /Library/Caches/*
sudo rm -rf /System/Library/Caches/*
atsutil databases -removeUser
sudo atsutil databases -remove
sudo atsutil server -shutdown
sudo atsutil server -ping
sudo rm -rf /var/folders/*

Restart immediatly

  • 1
    This was the only solution that worked for me, thanks!! – nathanvda Nov 6 '16 at 22:40
  • Mark as correct? – user2720970 Nov 8 '16 at 11:03
  • I am not the OP, so I can't :) I can only upvote, which I did :) – nathanvda Nov 8 '16 at 14:28
  • This worked for me! My system didn't want to shutdown when updating to 10.13.12. Clearing all caches worked. Thanks! – xinit Dec 11 '17 at 11:39
4

I also had this problem and I spent about an hour on the phone with Apple. It turns out that there was an issue with a 3rd party application.

Once i went into System Preferences > Users and Groups> then into Login Items and deleted all of the items in the list, my computer was able to shut down properly.

3

If you use Avid products you might try removing:

/Library/Audio/Plug-Ins/HAL/Avid CoreAudio.plugin/ 

or

/Library/Audio/Plug-Ins/HAL/Digidesign CoreAudio.plugin/ 

this was the cause of three of our computers not shutting down after the El Capitan upgrade. After removing the first shutdown will require sudo shutdown -r now from the terminal or press and hold the power button. This solved the problem for all three computers for us.

  • This solved my problem also. I had ProTools 9 on my Mac Pro. Removing that plug-in fixed it. (I plan to upgrade ProTools soon but as of this writing, apparently the latest version is not yet certified for the latest Mac OS). avid.force.com/pkb/articles/download/Pro-Tools-12-5-2-Downloads – David Barrows Sep 3 '16 at 17:27
  • This is happening to me with Pro Tools native on Yosemite, does this fix apply to Native? All the solutions on the DUC refer to this solution as an HD fix. Also, will I need to reinstall this core audio plugin? Seems a bit weird to just delete it... – joe_04_04 Oct 19 '17 at 9:14
0

If you have an update pending it may be trying to install that before shutting down and you are interrupting it. Check to see if you have any updates pending that require a restart. Mac OS X 10.11.1 is out and it requires a restart with a fair bit of time to install.

  • 1
    There are no updates pending, ive already checked – David Milburn Nov 12 '15 at 12:44
  • Have you let it run and see if it actually shuts down and how long it takes? It may be running cleanup scripts or some other mundane task. – ArchonOSX Nov 12 '15 at 12:46
0

I had this problem as well. I could not shutdown from the Apple menu or even logout. All desktop items and menu bar would disappear when I tried to shutdown, but the dock stayed and machine would never shut down. I could even reopen applications in the dock, except Finder. However, I could shut down by going to the Login Screen and clicking on ShutDown there. Tried all the usual resets, starting and shutting down in Safe Mode, etc.
After reading all the posts I could find, and trial and error, I discovered it was my fault. I had deleted application files (in my case, CiscoVPN) from my hard drive, without doing the uninstall process. I finally noticed that the iMac still had CiscoVPN as a startup item (Apple menu > About This Mac > System Report > Software > Startup items). I was lucky that the Cisco website included explicit instructions for removing CiscoVPN from Startup. I copy/pasted the lines from the Cisco instructions into Terminal, restarted the computer, and now it shuts down normally and quickly. Note that I don't believe CiscoVPN had a problem - it just happened to be the thing my iMac was looking for on startup and was probably still looking for it when I tried to shutdown. So check your startup items and make sure that if something is there, the application is also in your machine.

0

I had, and still have, the same problem. Something I have installed either needs updating or has become corrupt and I can't work out what it is. I have found a simple work around though. When you want to shut down, first close all open programs. Then BEFORE you choose shut down, choose "FORCE QUIT" Finder. When Finder starts itself again you should be able to shut down as normal without having to hold the power key down ( as I have been for months!) Good luck Tony

-1

I've had this problem with two iMacs at work since upgrading. Bizarrely, none of the macbooks around the office seem to be exhibiting this.

The only solution/workaround that I've found is to make sure the trash is empty before I shut down. I can't explain why this works for me but it just does.

Hope this helps...

You must log in to answer this question.

protected by Community Jul 26 '16 at 8:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .