0

My SuperDrive, USB connected to a 2012 Mac Mini with latest El Capitan OS X, has been working just fine until I tried to rip a purchased CD from a small singer songwriter. It hung up on the last cut and iTunes could not proceed to finish ripping the CD and eject the CD.

I tried to eject with the eject button, and by restarting the Mac. I would get a clicking sound from the drive on the restart but the disc would not eject. I unattached the drive and then reattached it and now the CD does not show up in the Finder sidebar at all. I used drutil also, got a clicking sound from the drive but would not object.

Does it sound like now the drive is destroyed or are there any suggestions how to get that disc out? Thanks so much for any help!

1

There are lots of ways to get the system to try ejecting the disk, most of them detailed here: http://www.wikihow.com/Eject-a-CD-From-Your-Mac

My favourite is restarting while holding down the mouse/trackpad button.

If the drive is making noises but the disk does not come out, it is possibly hitting or caught on the edge of the slot. I have had success in using something like a business card or piece of paper and inserting it above or below the edge of the disk (or using two cards, one above the disk and one below the disk). When the disk is being pushed out by the mechanism, rather than hitting the edge of the slot, it slides along the card and does not get prevented from being ejected.

  • 'Mousedown on boot' was already present on OS 6 and save my ass more than once. (First for floppies, later for CD's) – CousinCocaine Nov 12 '15 at 17:11

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .