There is a system process on my iMac running El Capitan called "symptomsd" that has been consistently bouncing back and forth between about 20% to 60% of the CPU resource on my iMac.

It is running from /usr/libexec/symptomsd. There is a private framework it loads called /System/Library/PrivateFrameworks/Symptoms.framework that itself contains other frameworks called:

  • ManagedEvent.framework
  • SymptomAnalytics.framework
  • SymptomEvaluator.framework
  • SymptomPresentationFeed.framework
  • SymptomPresentationLite.framework
  • SymptomReporter.framework

It doesn't seem to write much to the system log files. In fact the only relevant message in "All Messages" on the iMac is:

syslogd[46]: Configuration Notice: ASL Module "com.apple.networking.symptoms" claims selected messages. Those messages may not appear in standard system log files or in the ASL database.

There is a preference file at /private/etc/asl/com.apple.networking.symptoms that seems to indicate that logs should be written to /Library/Logs/CrashReporter/com.apple.networking.symptoms.log but that file doesn't even exist on my iMac.

I tried watching what it was doing with tools like fs_usage but I'm not getting much useful information back just lots of "ioctl" requests. I tried manually killing and triggering it to launch again, and it seems to examine all the applications installed on my iMac and then go back to making lots of "ioctl" requests.

Searching on Google all I've been able to determine is that this seems to be one of those things that is shared between OSX and iOS. No information anywhere on what it actually does though.

Anyone have any idea what this process is for or know anywhere it is documented?

  • 1
    Nice analysis so far, I haven't tried disassembling the program, but you should run sysdiagnose symptoms and possibly report a bug/feedback to Apple. I've not seen it misbehave on any system yet, but I'd check the rest of the system logs since my understanding is it relates to crash reporting, feedback and log aggregation/collection for improvement of OS X.
    – bmike
    Commented Dec 4, 2015 at 1:22
  • I'm seeing similar symptoms: high CPU load by "symptomsd". I also noticed "mDNSResponder" has high CPU load (about 50%). DNS requests were very slow and the system generally felt sluggish. Responsiveness returned once I killed (Force Quit) "symptomsd". Notably, "symptomsd" did not respawn automatically. Out of curiosity, are you using VirtualBox? System: OS X 10.11.4
    – Daniel
    Commented May 13, 2016 at 20:28
  • @Daniel I've used VirtualBox in the past, but not on the affected machine. Commented May 13, 2016 at 20:30

4 Answers 4


I have an iMac and had the same issue. It appears to be a bug in Mac OS X.

In my case, I had both Ethernet and Wifi turned on for my iMac. Turning Off Ethernet in System Preferences > Network, keeping Wifi as the only connection, prevents the issue completely. Now, the symptomsd consumes about 0.2 ~ 0.3 % CPU load as it's supposed to.

I started to experience only recently after upgrade to Mac OS X 10.11.1. I guess this is a bug introduced recently.

  • Thanks for taking the time to reply. I tried this, but it made no difference. :( Commented Dec 30, 2015 at 18:08

symptomsd runs as part of the CrashReportor framework.

  • There is no "CrashReporter.framework" on OS X. Do you mean "CrashReporterSupport.framework"? Commented Jun 6, 2016 at 20:15

I have the same issue with symptomsd process eating cpu (mouse lags and so on), when my mac connected to the web with LAN (thunderbolt 2 lan dongle) and Transmission working full force.

I guess i've found a fix for this, dunno if it works for you - goto network settings, choose your lan connection, goto advanced, choose hardware tab, then configure manually, change your duplex to "full-duplex, flow-control", other things leave as it is (mine is "speed-1000baseT"/ "mtu-standard 1500" / AVB enabled).

Hope this helps.


Not managed to find any conclusive information on symptond anywhere so far.

And not entirely confident in my fix, but turning off the firewall seemed to alleviate the problem for me anyway.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .