1

Mac Pro 2010 quad core, Mac OS X 10.6.8.

I have a USB 3.0 PCI card plugged in. When I tried to plug in a second external drive, I got this message:

enter image description here

I unplugged, and rebooted. Nothing plugged into the 2 USB 3.0 ports. I still get the message. Did I fry my card by just trying to use both ports? Any advice to troubleshoot this?

Edit - I just checked my eBay purchase history, the card is "Sonnet 2-Port Allegro USB 3.0 PCI Express Controller Card" and I bought it January 2014, so it ran pretty happily for almost 2 full years.

Final Update - After no luck with a couple reboots, I powered down, pulled the card, booted, powered down, re-installed card, then booted. No error message, card seems to function, although not nearly at the speed I thought I had. That's a different issue.

1

I'm pretty sure Snow Leopard does not provide native support for USB 3.0.

This is probably the main cause of your issue. You would need to make sure you have installed the proper drivers for your PCI card in order for the kernel to recognize and allow this new functionality.

Other possibilities:

USB 3.0 is inherently designed to draw way more power than USB 2.0. It's possible that when you plugged the device in, that's when the machine actually recognized the PCI card itself (or at least realized the necessary power consumption for running such a card and the fact that it was trying to draw more power than it was able to support).

Also:

Are you running any other PCI cards in your slots? The specific hardware you mentioned has a 300W max for all 3 PCI slots combined, so if you are sucking power from any other slots, this could definitely cause the issue you are seeing.

  • It worked for nearly a year. The card was sold as a 3.0 upgrade for the MacPro. When I booted into Yosemite, it didn't work either. It was good while it lasted. – JoeTaxpayer Nov 11 '15 at 20:43
  • See my updated answer and let me know if it can provide any additional insight. – rubynorails Nov 11 '15 at 20:47
  • 1
    2 slots have a PCI Card that let me add SSD. You're probably right. My points of concern/confusion - no issues till now, and even with USB card nothing plugged in, I get the message. I appreciate the help. – JoeTaxpayer Nov 11 '15 at 20:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .