So i recently downloaded BetterTouchTool but deleted it afterwards. During the time i had it i binded the keys (Space - w) to my mouse button 4 and some other stuff to other keys. After deleting BetterTouchTool all my other bindings have disappeared except for my mouse button 4. It is still stuck on Space W.

Please help it is a pain not being able to use it. I've tried my brothers mouse and its the same thing. His mouse button 4 is still recognised as space 2. It's like my laptop somehow recognises this button as Space w now even after deleting the original app. Even when setting the button into a game it is now not recognised as mouse button 4 or 3, it is now shown as ⌘[. Is there anything that i can do such as resetting my mouse options or like how my laptop recognises this one button?

Please help Thanks you

  • reinstall BTT, set everything back to default, uninstall. Deleting an app does not delete any system changes it made.
    – Tetsujin
    Nov 11 '15 at 6:46
  • Ive tried reinstalling BTT and i have clicked the RESET ALL option and then uninstalled it but still my mouse buttons are recognised as command and mouse button 4 is still (Space - W)
    – Stevy Lee
    Nov 11 '15 at 8:17
  • Oh i have been contacted by the maker of BTT and he says that my problem with my mouse is not because of it as i have tried reseting it all and unistalling it. He presume that my problem has something to do with my mouse driver software. Any idea about this? I have also tried rm ~/library/preferences/.Global* with no success
    – Stevy Lee
    Nov 11 '15 at 8:31
  • depends what mouse & drivers you have
    – Tetsujin
    Nov 11 '15 at 8:36
  • ebay.com.au/itm/… This is the mouse i have
    – Stevy Lee
    Nov 11 '15 at 8:45

There is a native keymapping tool within OS X itself in System Preferences > Keyboard > Shortcuts tab. There is a slight possibility that the change was made there, and you can change it manually.

The more-likely issue is that the software was not uninstalled completely when removed from your Applications directory. Lots of software nowadays comes included with uninstallers that you must run to remove stuff that gets distributed all over your filesystem (which is similar, yet not nearly as bad as the whole Windows Registry/AppData situation), yet I see this type of thing becoming more complex with each new version of OS X.

There is probably a .plist file out there somewhere that is getting loaded on startup or login that is controlling this unwanted behavior. Personally, I would go about resolving this in 1 of the following 3 ways:

  1. Re-download the app, and see if it comes packaged with an uninstaller. If so, run the uninstaller instead of dragging the app into the Trash.
  2. If the offending application did not come with its own uninstaller, download and install AppZapper, which is the absolute best uninstaller for OS X that I have come across to date. If you are familiar with Windows, it is the equivalent of RevoUninstaller for Macs. You simply open the AppZapper application, then drag the app from /Applications into the AppZapper window. AppZapper will automatically include all files that got installed elsewhere on your filesystem (such as ~/Library/*/*.plist, etc.) that are related to that application. Then simply click Zap! in order to remove all traces of its previous existence. I have absolutely no affiliation with this app, but recommend it often, because it's simply a must-have for me and has saved me much grief in the past.
  3. You can manually search out the offending .plist file, which is probably somewhere in ~/Library/LaunchAgents or ~/Library/LaunchDaemons, etc. Sometimes they are hard to find and oddly-named. First I would do a search for com.[better.touch.something.or.other].plist, but many times they follow the naming convention of the company or developer, which you may also try.

If all else fails, just sudo -s, start at / and start executing find commands (or better yet, in all of your Libraries -- if you are unlike me and remember where all of them are):

$ sudo -s
# find / -type f -iname "*.better*.plist" 2>/dev/null
# find / -type f -iname "*.btt*.plist" 2>/dev/null
# find / -type f -iname "*.boastr*.plist" 2>/dev/null

or maybe a better/faster way would be...

# find / -type f -iname "*Library*.plist"

...and see if anything stands out. If so, make a backup just in case you are mistaken, and then delete that sucker:

# rm [offending file].plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .