5

I have a Mid 2012 13 inch MacBook Pro that's been running successfully with a hybrid drive (3rd party) for the last few years. Recently, the operating system crashed and the hard drive is no longer recognised in recovery mode, so I purchased a 500GB samsung SSD to go into the machine.

I can successfully install Mountain Lion or El Capitan on the new SSD, but it never boots. I simply get any of folder with question mark / cancel symbol or flashing between the two when trying to run off that drive. Here's what I've tried

  • Boot in Recovery Mode, format drive as 1 partition (Mac OS journaled and using the Guid Partition Map), and then install OS X. This works successfully until trying to boot from the SSD. Boot in recovery mode and try and restore from time machine backup. This fails as it cannot create a recovery partition on the drive.
  • I've installed Mountain Lion successfully on an external USB drive, and have it up and running, from there, I downloaded the El Capitan installer and installed onto the SSD, which worked fine, but as soon as it came time to boot from the SSD, no dice.
  • I've created a USB installer from the El Capitan installer (using createinstallmedia), then used that USB drive to install to the SSD, and it all works to the point of trying to boot from the SSD, and then, no dice.
  • Throughout this process, Disk Utility in OS X and OS X recovery can successfully see and partition the SSD, and Verify Disk has never returned any errors, so as far as I can see, it doesn't seem to be hardware issue, but I cannot get OS X to boot from the disk (it boots fine from the USB I installed to).

Any ideas?

UPDATED: Just to clarify, in the Disk Utility in the El Capitan installer, I choose to partition the drive using the following options:

  • Name: OS X
  • Format: OS X Extended (Journaled)
  • Scheme: GUID Partition Map

This works without a problem, and the new partition appears. At this point, I choose "First Aid" which completes with no errors. "Info" on the partition created, shows "writable" yes, but "bootable" no, which I would expect at this point.

UPDATED: I've successfully installed Ubuntu 15.04 on the hard drive and it's working fine, and then I swapped the 500GB drive with a 240GB Samsung SSD and got exactly the same issue. Seems like I'll end up with Ubuntu on this machine, as I can't install either Mountain Lion, El Capitan or restore a Time Machine backup.

  • Have you tried starting up the disk using Startup Manager: hold down the Option ( ⌥ ) key immediately after hart restart. You should see a list of bootable volumes. If you see the SSD in the list, choose it, boot from it, (if it lets you,) and report back what happens. This page at Apple Support tells all about various startup options. – IconDaemon Nov 10 '15 at 23:32
  • Hi Icon, yes, I've tried that, and I can see the volume, and select it, but once I've chosen it, just won't boot. – Deeksy Nov 10 '15 at 23:38
  • You've formatted the SSD OS X Extended (Journaled), but did you also format with the scheme GUID Partition Map? Just double checking as you don't explicitly mention it. If you have formatted with GUID Partition Map, add that to your question to give more info up front. – IconDaemon Nov 11 '15 at 1:03
  • Hi, yes, thanks for your help, yes, I used that scheme. I've edited the question. Very odd that everything (including install) works perfectly, first aid on the OS X El Capitan installer looks good, yet it won't boot from that hard drive. – Deeksy Nov 11 '15 at 1:12
  • Just to clarify - was this drive internal & the only connected drive at the time of your experiments? If not, that would be my next attempt. I'd also call it 'Macintosh HD' just … well, just ;) 2nd test would be Internet Recovery rather than install from USB. – Tetsujin Nov 20 '15 at 7:53
2

You could try using bless to verify whether the disk is recognised as bootable and to potentially bless the disk to make it bootable.

If you can boot into Single User Mode (hold down command-S while booting) or launch terminal from an installer disk you can run bless

First I would try to establish if the drive is bootable or is flagged as the boot drive all by using

bless --info /Volumes/yourSSDdrive The state of your drive's blessed system folder

bless --info The state of the current boot drive's blessed system folder

bless --getBoot The current actual logical boot volume (e.g. /dev/disk1 )

If you find your drive is not blessed, you can bless it yourself with

bless --folder "/Volumes/yourSSDdrive/System/Library/CoreServices" --bootinfo --bootefi

See the man page for more details: https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/man8/bless.8.html

  • This is the kind of answer I've been looking for, thank you. I'll give it a go, but first have to backup the current Ubuntu system. – Deeksy Nov 18 '15 at 21:47
  • Hi, I've just done the OS X install again, and it failed to reboot to finish the install properly. After doing this, I ran bless --info /Volumes/OS X and it said that /Volumes/OS X/System/Library/CoreServices were blessed correctly. Still won't boot from that drive though. Is there anywhere where logs are kept of the boot process on the mac? – Deeksy Nov 19 '15 at 2:49
  • If you boot in Single User Mode you should see the boot logs display as the boot process starts. If you can get to Console app (I'm guessing not) the boot logs are in asl, which is also in /var/log/asl, you can read the asl logs with syslog – SJT Nov 24 '15 at 11:40
  • It does sound a bit like you have a faulty drive, though I'm not sure why Ubuntu would boot but OS X wouldn't. I have a Samsung SSD EVO 840 in my Macbook Pro and have had no problems with install or booting. – SJT Nov 24 '15 at 11:46
  • I'm now using that drive in my desktop machine (Windows) and it works fine, and swapped the other drive from my desktop machine into my MBP, and it's got the same issue (it's been running solidly for 2 years in my desktop). Bewilidering, but at this stage, it's probably just going to remain an Ubuntu machine till I get another one. – Deeksy Nov 24 '15 at 21:08
1

You didn't mention the type of SSD, if not recent, it may need a firmware update. I had problems with a Samsung SSD 850 PRO lately, after the second GUID and OS X Extended (Journaled) formatting of the SSD with Disk Utility: Carbon Copy Cloner couldn't create a recovery partition from El Capitan, I suspected something in the drive structure was deficient. Reformatting to GUID didn't help, I had to erase the SSD to ExFAT and MBR to restore it in its original state I guess, then reformat to GUID_partition_scheme and OS X Extended (Journaled), and it worked fine.

0

You didn't mention if prior to formatting the SSD you used Disk Utility to partition it as GUID (from the choices found after clicking the Options button in the Partition Tab). That may be what's preventing it from booting the system. Check that out and make that change if necessary then reinstall your OS and see if it will boot your laptop.

  • Hi, thanks for your help. I've added info to the question to make that clear now. I've definitely done that. In addition, in the OS X installer, I can open terminal and cd to the volume, edit and add files etc., so it doesn't seem like a hardware issue. – Deeksy Nov 11 '15 at 1:33
0

Turns out this is symptomatic of a SATA cable issue. Seems like writing to the drive was fine (hence installing wasn't an issue), but reading from the drive was causing the issue. Verify and Repair disk in the installer weren't picking up the issue.

Replacing the SATA cable fixed the problem.

0

Had the same problem. Found the SSD connector not made as thick as HDD connector this causes contact problem. Quick fix is to cut two thin pieces of printer paper to use as shims to wedge the contacts together. Make them long enough so you can hold them in place as you insert the cable with the SSD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .