OS X El Capitan.

I have seen this thread, and it explains a bit (different reporting units), but there is an additional substantial discrepancy in the free HDD space of an external HD reported:

  • Get Info : 11.22GB
  • df -h : 1.3Gi
  • About This Mac - Storage : 1.42 GB

Screenshot of the different disk free info

So the differences between About This Mac and df -h can be according to the different units - but the Get Info is heavily off?

Any ideas what is going on there?

I know for a fact that the df -h and About This Mac are correct as I can not copy anything larger than the 1.4 Gb on the disk.


These are the hidden files and folders - the rest is stuff I put there:

$ ls -la
-rwxr-xr-x   1 rainerkrug  staff       14340 Nov 10 14:51 .DS_Store
drwx------   5 root        staff         170 Nov 10 18:19 .Spotlight-V100
d-wx-wx-wt   2 root        staff          68 Nov 10 17:36 .Trashes
-rwxr-xr-x@  1 rainerkrug  staff         313 Mar 15  2015 .apdisk
drwx------  15 root        staff         510 Nov 10 18:24 .fseventsd

and their disk usage:

$ sudo du -sch .[!.]* *
 16K    .DS_Store
 11M    .Spotlight-V100
  0B    .Trashes
4.0K    .apdisk
 52K    .fseventsd

You could try sudo mdutil -E / on the terminal, to reindex Spotlight.

  • Why do you think spotlight has anything to do with it? – Rainer Nov 12 '15 at 21:14
  • Because the report you look at on the get info window comes from the index. I'm telling you this because I had the same problem, 9.7GB of 'extra space' on every writeable disk connected on my computer, even a 1GB usb stick showed 10GB of free space, it was driving me crazy. So, what I did besides disabling Time Machine and the backup space with 'sudo tmutil disablelocal' in Terminal was to reindex my Spotlight. After that the readings went back to normal. – Daniel Garcia Nov 13 '15 at 19:05
  • OK - this worked - I used sudo mdutil -E /Volumes/MyPassport2TB. This deleted the index without touching the one from the internal hdd. If you could add the information in the comment why this works, I will accept the answer. – Rainer Nov 16 '15 at 14:44
  • Please make your answer more comprehensive and add why this helps. – Rainer Nov 19 '15 at 9:14
  • The problem arises because Time Machine stores the backup that is going to save to the T.M. Disk the next time it's connected, for instance, if your next backup is 5GB, and you are away from home (where you have your Time Machine Disk), the backup is prepared before it's transferred to T.M. So, Finder shows you the space you have free subtracting the backup, because that's going to T.M. Which I consider a dumb implementation from Apple, just because it leads to this kind of problem we had. I don't see the problem of reporting that space in T.M. and leave the borrowed space reported in Finder – Daniel Garcia Nov 20 '15 at 20:57

The problem is that Finder ignores all space taken up by backups. As it detects and shows you in "About this Mac", you have about 9 GB of backups. "Get Info" reports the 2 GB of free space and 9 GB of backups. So, disabling and reenabling time machine may solve your problem, if it matters that much.

  • OK - that makes sense. But how can I delete the backups from the terminal if I need the space, apart from disabling and reenabling tIme Machine? – Rainer Nov 10 '15 at 16:38
  • Just to add to it: this is not my system hdd - and on the external hdd there is no folder .MobileBackups as is on the internal hdd. – Rainer Nov 10 '15 at 16:48
  • Try showing all hidden files and see what you find by: Opening Terminal and typing defaults write com.apple.finder AppleShowAllFiles YES. But, don't delete anything until you have researched what it does. I'm not near a computer right now, so I don't know what you'll find. – SentientBacon Nov 11 '15 at 1:26
  • I have used ls -la and added the info in the question. but they are very small and negligible. – Rainer Nov 11 '15 at 13:42
  • 1
    I just tried to disable and enable Time Machine Backups, and nothing changed on the external hdd - on the internal I gained about 12 GB, but nothing on the exeternal. I did a hdd check from Disk Utility and everything is OK. – Rainer Nov 11 '15 at 13:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .