I am plugging a USB Ethernet adapter (not Apple-brand) into my MacBook Pro (Retina, 15-inch, Late 2013). No go.

I do not see any relevant "USB Ethernet" item listed in System Preferences > Network. Should one appear when I plug in the adapter? Should I add an item with the "+" button?

enter image description here

When I use the "+" button, I only get a list of "Thunderbolt Bridge", "Thunderbolt 2", "Thunderbolt 1", "Bluetooth PAN", "Wi-Fi", "VPN", "PPPoE", and "6 to 4". I do not see any option for a USB-Ethernet adapter. Is this no longer supported by Apple?

enter image description here

The Apple menu > About this Mac > System Report (button) > Hardware > USB report shows that I have a product by Realtek Semiconductor Corp. (company web site)

enter image description here

  • Can anybody help where to get the USBCDEthernet.kext ? I installed the quantum USB to Ethernet driver(IC is of Realtek) but it did not provide the .kext. From where do I get this .kext file?
    – user194328
    Commented Jul 31, 2016 at 17:14

7 Answers 7


For Realtek based USB 2.0 or 3.0 Ethernet Adapters, you can get the driver from Realtek which works for both 8153 and 8152.

  • 2
    Thanks for this, this is the new correct answer. The previous answer by @[Aaron Wallentine] and @inkandfeet requires using csrutil disable which opens your system to malware. Commented Mar 21, 2017 at 18:09
  • 1
    I have done this but it did not work
    – alper
    Commented Dec 13, 2019 at 10:20

As far as I understand, you can run a lot of generic ones that don't have Apple-signed drivers by disabling "System Integrity Protection" (SIP)

From: http://inkandfeet.com/how-to-use-a-generic-usb-20-10100m-ethernet-adaptor-rd9700-on-mac-os-1011-el-capitan

Steps to get your adapter working if you've never used the adapter before in Mac OS 10.11 El Capitan.

  1. Uninstall the dozens of other drivers you may have installed in the process of trying to get this working.
  2. Unplug your USB adapter, and reboot and give yourself a clean slate.
  3. Reboot. As soon as the screen goes black, hold down "Command" and "R" until you see a black screen with an Apple logo and a white progress bar. Let go, and wait for your computer to boot into recovery mode.
  4. From the top bar, select "Utilities" and then "Terminal"
  5. In the terminal, run csrutil disable.
  6. From the top bar, select "", then "Restart"
  7. Once you're booted back up, download and install the drivers from the CD, kindly uploaded by this fine human being.
  8. Reboot.
  9. Open your terminal, and run sudo kextload /System/Library/Extensions/USBCDCEthernet.kext
  10. Reboot.
  11. Plug in your USB Adapter, with a live ethernet cable.
  12. Open System Preferences, and go to the Network Pane.
  13. Hit the + button in the bottom right, select the "USB 2.0 10/100M Ethernet Adapter", and hit add.
  14. You're all set! Your adapter works!
  15. Apologize to the people you care about for the things you've said over the past few hours. They won't understand, but they will forgive you.

I presume that any driver that worked for these types of things pre-Yosemite (10.10) would work for the ones in step 7.

See original page for a discussion on the security risks of using this method. But, if you need it to, and are aware of and OK with the risks, it works.

This worked for me on El Capitan (10.11) with a random off-brand adapter (can't remember the brand or if it even had one).

  • 1
    Just to comment that this worked for me with this adapter. You can re-enable SIP after installing the driver.
    – starfry
    Commented Dec 16, 2016 at 11:27
  • 6
    This answer was pretty useful but RealTek - the makers if the 8152/8152B and 8153 Ethernet chips that are used by the majority of these generic USB connectors released an official, signed driver here: realtek.com.tw/Downloads/…. Please use this because csrutil disable creates a security risk Commented Mar 21, 2017 at 18:06
  • 1
    I hate Apple so so so so much, new company is forcing me to use one of the latest macbook pro and I'm having to deal with this issue and many many more. Commented Nov 8, 2019 at 18:24
  • @IvanCastellanos Ask the company to install Windows or give you an official Apple dongle. Commented Jul 17, 2020 at 22:23
  • Guys I installed driver from @EricKigathi link. But my Ethernet sometimes still disconnecting... any more ideas?
    – Bimawa
    Commented Aug 26, 2020 at 4:42

Old post, but just wanted to give an update.

Sometimes you just need to install the chipset's drivers.

Asix Driver

If you are lucky, you will have an Asix's chipset and you can do the folling to find the proper USB ethernet adapter drivers in macOS.

  1. find the adapter chipset in The Apple menu > About this Mac > System Report (button) > Hardware > USB report. USB report

My adapter chipset model is AX88772B, Manufacturer is ASIX Elec. Corp.

  1. Google ASIX Elec, find it's official driver downloader page

  2. Locate AX88772B in the web page (Software & Tools > Drivers > USB Ethernet ICs). AX88772B

  3. Download the driver matching your macOS version. enter image description here

  4. install the driver.

  • 4
    Link is broken. Perfect example of why to summarize the content of the linked material in the answer. Downvoted. Commented Aug 16, 2018 at 15:16
  • Please switch the language to English before taking screen shots. Commented Jul 17, 2020 at 22:23
  • 2
    This answer helped me after updating to Big Sur. Commented Nov 25, 2020 at 20:18

For a Cable Matters adapter, I had to get the drivers from here: http://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131

  • 1
    Yup, Cable Matters USB 3.0 AX88179. Thank you!
    – Ryan Allen
    Commented May 12, 2018 at 19:34

If your adapter wasn't specifically advertised as Mac-compatible, then its unlikely to work. There are a couple of 3rd party brands that positively will work but I wouldn't trust just any off brand adapter and if its a PC manufacturer brand, then it definitely won't have the internal circuitry that a Mac-compatible adapter will have so the answer, unfortunately is just... no.

See: [Do I have to use the Apple USB Ethernet Adapter for a MacBook Air? for further details on adapters that definitely are compatible.


A proper instruction for RD9700 is here https://www.technouz.com/3973/how-to-use-a-generic-usb-ethernet-adapter-rd9700-on-mac-os-x/

This is the only manual I've found so far that has ALL necessary steps. In particular step 7 is critical (install drivers from x86_64 folder).

I managed to get my noname adapter working, but the internet speed is only 5mbps although I have 100mbps connection :(

Step 1: Unplug your USB adapter.

Step 2: Restart your Mac by clicking the Apple logo in the top-left corner and then Restart. As soon as your machine restarts, you’ll hear the Apple chime. Hold down CMD + R immediately after hearing the chime to boot in to Recovery Mode.

You can release CMD + R once you see the Apple logo and a progress bar.

Step 3: From the top bar, select Utilities and then Terminal.

Step 4: In the terminal window, you need to type the follow and then hit enter: csrutil disable. You may be prompted for your Administrator password.

Step 5: Now from the top bar, click the Apple Logo and then Restart.

Step 6: Your Mac should now restart back in to the normal operating mode. It’s time to install the drivers. Click here to download the zip file and extract it to your Desktop.

Step 7: Install the RD9700 driver located in the x86_64 folder and then restart your Mac again.

Step 8: Once your Mac has rebooted, open Terminal and enter the following then press the Enter key: sudo kextload /System/Library/Extensions/USBCDEthernet.kext.

Step 9: Reboot again.

Step 10: Now plug-in your USB Ethernet Adapter with a live ethernet cable. Open System Preferences and go to Network.

Step 11: Press the + button in the bottom right and select USB 2.0 10/100M Ethernet Adapter and then click Add.

Step 12: Disconnect from WiFi and you should notice your network connect still works through the RD9700 Ethernet Adapter. In addition, you will be able to share internet using the RD9700 too.


You don't describe which adapter you might have bought, but if the OS does not provide a driver for it, you will have to install a driver from the manufacturer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .