1

When I open MacVim (installed with homebrew) in the GUI, the Explorer works as expected. But if I open "vim" in a terminal, I've got that message:

E492: Not an editor command: Explorer

But the netrw is installed. This is what return :scriptnames

4: /usr/local/Cellar/vim/7.4.712_1/share/vim/vim74/plugin/netrwPlugin.vim

vim --version

VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Aug 14 2015 16:38:12)
MacOS X (unix) version

brew info macvim

macvim: stable 7.4-81, HEAD
GUI for vim, made for OS X
https://github.com/macvim-dev/macvim
/usr/local/Cellar/macvim/7.4-77 (1905 files, 34M)
  Built from source
/usr/local/Cellar/macvim/7.4-81 (1918 files, 35M) *
  Built from source
From: https://github.com/Homebrew/homebrew/blob/master/Library/Formula/macvim.rb
==> Dependencies
Recommended: cscope ✔
Optional: lua ✔, luajit ✘
==> Options
--with-custom-icons
    Try to generate custom document icons
--with-lua
    Build with lua support
--with-luajit
    Build with luajit support
--with-override-system-vim
    Override system vim
--with-python3
    Build with python3 support
--without-cscope
    Build without cscope support
--without-python
    Build without python support
--HEAD
    Install HEAD version
==> Caveats
.app bundles were installed.
Run `brew linkapps macvim` to symlink these to /Applications.
6
  • Try just vi. Also what do you get with which vim?
    – user14492
    Commented Nov 9, 2015 at 18:23
  • vi bring me into vim and which vim gives /usr/local/bin/vim Commented Nov 9, 2015 at 18:42
  • First try which -a vim, you should only get one path. My vim is installed at /usr/bin/vim. Open your file with full path of vim i.e. usr/bin/vim. I think you have a third party vim installed. vim comes pre-packaged with OS X, have a look in your .bashrc and .bashprofile the culprit should be there, creating an alias to the third party command.
    – user14492
    Commented Nov 10, 2015 at 0:12
  • Yes, you're right, I've got 2 vim, and the one I launch is the one I installed with homebrew. I think I had some conflicts with my vim plugin and the built-in version of vim. But why my vim does'nt find the Editor when launched form the terminal ? I've updated my question with hombrew. Commented Nov 11, 2015 at 10:03
  • Er, have you tried :Explore? Commented Apr 29, 2020 at 18:47

1 Answer 1

-1

I had no .vimrc yet, when I added a .vimrc file, the Explorer worked without any problem.

But even without .vimrc or .gvimrc, the Explorer worked correctly in MacVim.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .