3

The latest version of Visual Studio Code will not run ("can't be opened" is the unhelpful error) when I copy it to the applications folder. It runs fine after unzipping to the Downloads folder, but just wont from the applications folder.

I don't think it's the security setting as that's already set to allow apps from anywhere.

OS X El Capitan on a Mid-2014 Macbook Pro

3
  • I'd check the execute bit is set for everyone; I've had vague weirdness like that, where the actuall app inside the package didn't arrive with execute perms
    – Tetsujin
    Nov 9 '15 at 11:03
  • any link as to how? its not my main machine, and not had to do this before.
    – cjb110
    Nov 10 '15 at 10:00
  • Use BatChmod Open the file, ensure 'X' is ticked for owner, group & everybody, check 'Apply to enclosed', Apply.
    – Tetsujin
    Nov 10 '15 at 14:45
10

I had this issue and I found a workaround, which may work for you...

  1. Unzip Visual Studio Code in the download folder.
  2. Right-click Visual Studio code, in the download folder, and select 'Open'. If you're prompted by Gatekeeper, open the application.
  3. From the 'Code' menu, select Preferences > User Settings.
  4. Once the settings files open, you can immediately close them both.
  5. From the 'Code' menu, select Preferences > Keyboard Shortcuts.
  6. As with #3, you can immediately close the files.
  7. Quit Visual Studio Code
  8. Copy the Visual Studio Code application into your Applications folder.
  9. Open it from Applications.

This worked for me - I have no idea why, perhaps a bug to do with accessing the preference file(s)? Maybe this might work for you?

1
3

Moving the Visual Studio Code.app into the ~/Applications folder instead of /Applications worked for me.

1
  • The other way around worked for me. All of my other apps were in the /Applications. Moving the VS Code app from ~/Applications to /Applications solved the issue.
    – tozCSS
    Jul 11 '19 at 16:46
0

Just place distribution archive (VSCode-darwin.zip) in /Aplication folder and extract it in the same place. Remove archive after expand.

0

That's because of the extended attribute com.apple.quarantine, you can use xattr to remove it from any downloaded app, e.g.:

xattr -d -r com.apple.quarantine "/Applications/Visual Studio Code.app"

Note: use sudo to run the above command when necessary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .