2

The latest version of Visual Studio Code will not run ("can't be opened" is the unhelpful error) when I copy it to the applications folder. It runs fine after unzipping to the Downloads folder, but just wont from the applications folder.

I don't think it's the security setting as that's already set to allow apps from anywhere.

OS X El Capitan on a Mid-2014 Macbook Pro

  • I'd check the execute bit is set for everyone; I've had vague weirdness like that, where the actuall app inside the package didn't arrive with execute perms – Tetsujin Nov 9 '15 at 11:03
  • any link as to how? its not my main machine, and not had to do this before. – cjb110 Nov 10 '15 at 10:00
  • Use BatChmod Open the file, ensure 'X' is ticked for owner, group & everybody, check 'Apply to enclosed', Apply. – Tetsujin Nov 10 '15 at 14:45
8

I had this issue and I found a workaround, which may work for you...

  1. Unzip Visual Studio Code in the download folder.
  2. Right-click Visual Studio code, in the download folder, and select 'Open'. If you're prompted by Gatekeeper, open the application.
  3. From the 'Code' menu, select Preferences > User Settings.
  4. Once the settings files open, you can immediately close them both.
  5. From the 'Code' menu, select Preferences > Keyboard Shortcuts.
  6. As with #3, you can immediately close the files.
  7. Quit Visual Studio Code
  8. Copy the Visual Studio Code application into your Applications folder.
  9. Open it from Applications.

This worked for me - I have no idea why, perhaps a bug to do with accessing the preference file(s)? Maybe this might work for you?

2

Moving the Visual Studio Code.app into the ~/Applications folder instead of /Applications worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .