0

Having discovered the excellent SafariKeywordSearch thanks to an answer here, I'd now like to get rid of the warning which Safari pops up on launch about Keywurl not loading because it hasn't been tested with Safari 5.1.

I thought I had circumvented this by deleting the Keywurl bundle from ~/Library/Application Support/SIMBL/Plugins (it had only been installed locally, not globally), but Safari still stubbornly pops up a warning. In actual fact, I was seeing two instances of the incompatibility popup before I performed this deletion, but that second one still persists. I've used Spotlight in an attempt to track down the phantom second instance, but without success.

Has anyone any idea where it might be lurking?

1
  • Following through on my own efforts to remove this annoying popup, I have also removed SIMBL itself, thinking that might help. It didn't. Aug 11, 2011 at 18:23

3 Answers 3

1

From Keywurl's ReadMe:

Installation

Copy Keywurl.bundle into Library/Application Support/SIMBL/Plugins under your home folder, or in /Library/Application Support/SIMBL/Plugins in the hard drive root if you want Keywurl to be enabled for all users on the computer.

Uninstalling

To uninstall, just delete the file you copied.

You said you mentioned that it was only installed locally, not globally, but I've had issues with other SIMBL plugins where I thought they were installed locally only to find another copy lurking at the system level.

So I'd check /Library/Application Support/SIMBL/Plugins as well, just to be sure. Note that this is a different hierarchy than the one mention in Gio's answer.

Make sure that you quit/relaunch Safari after you do this. A logout/restart might also help.

4
  • I had already checked there, but the Plugins folder was empty. Aug 11, 2011 at 23:22
  • 1
    Maybe a silly question - have you restarted since removing the folders? I know that SIMBL loads the plugins at runtime and so a simple quit/relaunch should suffice, but maybe it's still loaded in memory even though it's been trashed?
    – Gauzy
    Aug 11, 2011 at 23:33
  • I had quit and relaunched Safari several times during the process, but apparently one time too few. A further quit/relaunch in reaction to your suggestion has returned my sanity - no popups any more; no reference to Keywurl. Thanks. Aug 11, 2011 at 23:42
  • Glad that did it! I've experienced the behavior you've described before as well with other SIMBL plugins. Good to hear that it's all sorted out. I've updated my answer as well.
    – Gauzy
    Aug 11, 2011 at 23:43
0

The folder to delete should be ~/Library/Application Support/Keywurl

1
  • Unfortunately, that folder doesn't exist, and neither is there such a folder at the System Library level. Aug 11, 2011 at 23:10
0

The keywurl plugin cannot launch without SIMBL being present. It must still be on your system.

Open Activity Monitor and look for SIMBL Agent. If it running, then click the Sample Process icon. Look at the report produced - you will see the filename of the process - tho will give you a clue where the remnants of SIMBL are lurking on your system.

Kill the SIMBL agent process - then open Safari - you should find that the message is no longer popping up.

Then you need to delete the remnants of SIMBL on your system. Probably the best way to do that is to reinstall it, and then deinstall using the official uninstaller. If that doesn't work, delete the file listed by Sample Process by hand.

2
  • Thanks for the input, but the problem has now been solved. Gauzy's nudge towards a relaunch of Safari (above) finally did the job. As mentioned in a comment response to Gauzy, I had already quit and relaunched Safari several times during the ongoing process, but apparently all this was still one relaunch too few. Aug 12, 2011 at 4:37
  • Glad it got fixed!
    – dan8394
    Aug 12, 2011 at 4:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .