0

I purchased my MacBook Pro (Retina, 13-inch, Early 2015) just a few months ago for one specific purpose. I use it at my church to run the projector. It's connected through VGA, so I've been using a MiniDisplay to VGA adaptor (Apple Online Store). It worked great until last week. All the sudden it wouldn't recognize the Projector display. Sometimes I can get it to work for 30 seconds or so, then it may flicker in and out some and go away or sometimes it just drops the signal right off the bat. During troubleshooting I tried hooking into a couple flat screens via VGA and got the same thing. I've confirmed that everything else from the projector to the adaptor work correctly.

At first I thought it may be a short in the MiniDisplay to VGA adaptor so I bought 2 more adaptors and tried them and still had the same problem. My friend brought his Macbook Pro and it worked perfect using all 3 adaptors. So I've been able to narrow the problem down to the MBP, but I have no clue what it could be. I've tried resetting PRAM and Management Unit even though I don't think that applies to the MBP.

I'm running Yosemite 10.10.5. I haven't upgraded to El Capitan yet due to my presenter software not being compatible with it yet. I would really appreciate any advice. Not sure if this is a software or hardware issue either? Thank you in advance!

1

Since the MBP is so new, you should probably contact Apple right away. You have eliminated all but your new Mac as the problem. Let Apple fix it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .