0

This question already has an answer here:

Over a year ago I bought a second hand MacBook Pro on ebay. Unfortunately the original owner did not reinstall the operating system and in fact it came together with Photoshop and Microsoft Office.

My problem is that I am unable to update certain apps (e.g. iPhoto and iMovie), strangely enough I managed to update from Yosemite to El Capitan.

I tried to format and reinstall the operating system, as many forums suggest doing, however when opening the App Store I still get a prompt to login with the previous owner's email address and I am unable to proceed. Also it's strange that despite reinstalling the OS, I still have pre-installed Photoshop and Office.

I would prefer not having to contact the owner asking for his password.

What can be done? Did I do something wrong during the OS reinstall (considering Photoshop and Office are still on it)?

marked as duplicate by Tetsujin, Mark, klanomath, IconDaemon, jherran Nov 8 '15 at 4:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You'd need to erase, then reinstall OS X. The drive (and all applications as well as the authentication data for that user's Apple ID are kept during the reinstall of OS X. Erasing the drive completely will remove all traces of any data on that drive. However, it will also delete all of your files. I'd recommend doing a manual backup and copy all the files from your desktop, documents, etc. to an external drive. Then enter recovery HD, erase the drive, and reinstall OS X.

  • I've already tried it once and I still seem to have the same problem. I am just worried about having to go through the whole process of backing up and reinstalling again and then having the same problem – Martin Nov 7 '15 at 17:16
  • @Martin if you erase the drive, then you can create a new user with you're Apple ID. Then you can download the apps you legally purchased – At0mic Nov 7 '15 at 19:37

Not the answer you're looking for? Browse other questions tagged .