0

After applying the Yosemite 10.10.5 update and Security Update 2015-004 (1.0), my installation of Outlook 2011 prompts me for a password every time I check for mail. I have tried repairing Keychain Access a few times (on Verify, it says there is never a problem) and deleting/recreating the keychain login entries for Outlook, but I continue to be prompted to reenter my credentials:

Prompt from Outlook after forgetting password

Adding keychain entry

After entering the credentials, I show as connected and can send/receive all my mail. There is also a login entry displayed in Keychain Access. But the prompt still appears on every send/receive.

I have seen this solution of adding an additional backslash to the beginning of the domain (i.e. \domain\user instead of domain\user ) but doing so returns a bad user/pass error.

The 10.10.5 update description says it "improves compatibility with certain email servers when using Mail" - thinking this might be a clue?

My coworker's mac (which hasn't been updated) does not have this issue, and my iPhone and Win7/Outlook 2007 installs are receiving mail from the same account with no login problems. Mail server settings have not changed (I manage it).

EDIT

Reviewing the keychain entry after getting the wrong credentials prompts, I see that the username has been changed from domain\username to username@example.com but the prompt keeps coming up suggesting domain\username. (Attempting username@example.com fails with bad user/pass error.) The change to the keychain entry occurs when relaunching Outlook or after a period of time.

1

The Exchange "autodiscover" settings changes the server URL to the WSDL resource.

So, mail.domain.com becomes: mail.domain.com/EWS/Exchange.asmx everytime you check for mail.

To fix this, you have to tell Outlook to stop asking for autodiscover settings using AppleScript editor:

tell application "Microsoft Outlook"
set background autodiscover of exchange account "NameOfAccount" to false
end tell

credit: http://www.officeformachelp.com/2011/01/exchange-autodiscover-workaround-for-advanced-settings/

  • Thanks for the advice - I actually did play around with turning on/off autodiscover but I had a few things wrong (which I will edit in my original post) - my coworker with the same setup did in fact have the same problem with her installation. The connection string changes were a red herring. The problem had to do with a public mail folder in Exchange that had some permissions issues. Known issue from M$ and they're apparently working on a patch. Only affects Exchange 2013 installs that were migrations from 2010. – Kristen Waite Dec 26 '15 at 20:30
  • cool, glad you found a solution :) – Nathan Boolean Trujillo Dec 28 '15 at 21:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .