4

For one of the artists on my iTunes music library, I've purchased music from iTunes Store. With iTunes 12, there's now a Biography panel and Similar Artists panel on the right that I can't get rid of - so far I've disabled "Show Apple Music" in the General preferences, and I've also disabled "Apple Music Connect" in the Parental preferences. Unfortunately it's still showing. Is there any way to not have that panel show?

  • 1
    I've reverted to iTunes 10.4.1, which doesn't have that panel. That's probably not the way you want to go, but it does work. – Wayfaring Stranger Nov 7 '15 at 3:42
  • @WayfaringStranger Indeed I suppose that is a solution, albeit not ideal. Hoping there's some odd command line / .plist hack that'll change it though. – andrewb Nov 7 '15 at 3:55
2

I have yet to update my iTunes (and now I'm starting to think I should avoid it all together!) I was, however, able to search an Apple discussion board and found this to be the closest fix (hopefully) to what you are asking for:

Go to Edit>Preferences>Parental>Check the Apple Music Connect>Restart iTunes.

Apparently this user has a PC but they said they assume it will be easy to do on a Mac as well. Here's the link to the discussion board I referenced. Hope this helps!

  • Didn't work for me. – ghoppe Dec 10 '15 at 23:22
  • This does, indeed, work for me on iTunes 12.4.3.1 and OS X 10.11. However, unfortunately the column with all my music in it doesn't get very much wider, which was the whole reason I looked for this! The right side of the window is now just a large empty space. So much info truncation. Booooo, Apple. – Bryson Aug 9 '16 at 16:40
1

By changing the width of the window, or increasing the width of the sidebar, the third column you speak of will disappear.

0

I found the solution:

  1. Select the songs/album purchased from iTunes store.

  2. Go to File >> Convert >> Create AAC version.

  3. Delete original songs.

  4. Restart iTunes.

Problem solved.

0

Go into iTunes Store after following the 4 steps from Mac User and make sure said albums are taken out of your purchased history....don't worry if you need to redownload you can do so by going to your account and to purchases from there...or that's atleast if you have hidden the cloud bs...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .