4

After upgrading to El Captian, OpenVPN displays the following error when attempting a connection: "JSONDialog: Error running jsondialog".

I'm using OpenVPN version 2.0.9.201.

How do I get OpenVPN to work without disabling SIP?

4

Short answer, you can't.

However, at work we had this issue. Some machines that previously had OpenVPN installed prior to upgrading to El Capitan had no problem.

Others required that we run the uninstall script for OpenVPN. Then disable SIP, install OpenVPN, then re-enable SIP when you are done. Annoying, and a bit time consuming, but the end result is that you have OpenVPN installed and SIP is enabled.

This has worked on multiple Mac's at our office.

The other alternative was to use Viscosity which does not require SIP to be disabled, but has a small licensing fee. I have heard that Tunnelblick also works, but have not personally tried it.

  • The long-winded SIP method worked for me, though it's not ideal. Cheers. – cw-nom Nov 30 '15 at 11:45
  • I switch to using Viscosity...seems to be working like a charm: sparklabs.com/viscosity – brianz Jun 21 '16 at 21:30
  • @brianz Yes, we switched to Viscosity in-house and it works great. – bayendor Jun 22 '16 at 22:07
1

Without the trick from bayendor to disable SIP, install openvpn, reenable SIP, you can also use Tunnelblick.

It does work even with System Integrity Protection enabled.

  • Yes, some of our devs were already using tunnelblick, and we confirmed it worked fine without disabling SIP. It's just that OpenVPN for Mac has not been updated in what seems like forever. – bayendor Jun 22 '16 at 22:08
  • I confirm Tunnelblick is working out of the box, no problem, no hassle, does the same as OpenVPN app. Thank you, just saved my life. Grateful forever! – Aston Sep 8 '16 at 12:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .