9

Is there a way to enable the bell terminal and other sound notification from the terminal, while my "play user interface sound effect" setting is off ?

I don't like to have any sound notification (I prefer the flashing screen), but I'm using weechat and I wish I could enable some sound notification in it.

11

You can create separate profiles one with sound disabled (default) and one with sound enabled (for your weechat). These are available both in Terminal and iTerm2.

Terminal enter image description here

iTerm2

enter image description here

  • 1
    thanks for your answer and to took the time to take screenshot. maybe I should have been clearer : in System Preferences / Sound / Sound effect , I disabled the "Play user interface sound effects", cause I don't want any sound from the U. So what I'm looking for is a solution to overwrite this setting just for the terminal/iterm2 maybe there is a way with a command line. – aroom Nov 6 '15 at 16:24
  • For me that Play user interface sound effects settings doesn't have any effect on terminal bell sound (El Capitan 10.11.1) – sdayal Nov 6 '15 at 16:45
  • you are correct. I stand corrected - my alert volume was all the way down. sorry and thanks for your help – aroom Nov 6 '15 at 16:59
  • but now, I wish I could get the alert for the terminal exclusively. any idea ? – aroom Nov 6 '15 at 17:06
  • It disables sounds like dragging items to trash, but for sounds inside terminal the profile settings takes preference. Do you hear a bell in terminal window on pressing say F10 with Play user interface sound effects disabled but Audible Bell enabled? – sdayal Nov 6 '15 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .