3

I've updated from Yosemite to 10.11.1 on my mid 2014 macbook pro a few days ago. I've got a WLAN in my apartment (for other gadgets), but since the signal is a bit weak at my desk, I have connected the macbook to the router using a LAN cable and a thunderbolt-ethernet adapter and switched WLAN off on the macbook. All was well on Yosemite, but El Capitan insists on switching on WLAN during most boots. Is there any way to prevent this without removing admin rights from my user and without removing the WLAN network from the list of known networks?

I'm concerned about the potential security issues (in case it might connect to open networks when I'm traveling). It's also a nuisance because WLAN seems to take priority over the ethernet connection, which means I have a slow and unstable connection until I remember to switch WLAN off again.

I guess I could create a new user without admin rights. Since I made sure that admin rights are necessary to activate WLAN that should prevent the issue, but I would prefer to avoid this "solution".

  • I'm not too experienced with Mac Wifi, as I've only recently added a wifi card in my old Mac Pro… but how about system prefs > Network > Wifi > Advanced... > Wifi - require admin to Change Networks? – Tetsujin Nov 5 '15 at 18:42
  • @Tetsujin See the last two sentences. Apparently that doesn't help if the user got admin rights. – Roland Nov 5 '15 at 18:43
  • ah, ok - forget that then ;) – Tetsujin Nov 5 '15 at 18:51
  • Go to System Preferences > Advanced > TCP/IP remember the local IP. THen type ifconfig, and search for the same address. Above should be an interface (en1, or wlan0). What interface is the one above that address? – TheBro21 Nov 5 '15 at 19:21
  • 1
    @TheBro21 WLAN is en0. – Roland Nov 5 '15 at 19:34
4

Your question touches upon a few different areas so I will aim to address these individually:


Disabling a network service

You did not mention how you were disabling the Wi-Fi (i.e. WLAN) service, however there are generally two ways to do so from System Preferences in OS X:

  • Click the Apple menu (), then System Preferences, then Network
  • Click Wi-Fi or the custom-named service from the service list on the left
  • Click Turn Wi-Fi off, then close the System Preferences window

Alternatively:

  • Click the Apple menu (), then System Preferences, then Network
  • Click Wi-Fi or the custom-named service from the service list on the left
  • Click the gear icon (⚙), then Make service inactive, then click Apply

Both methods should persist through a reboot or shutdown. Neither method requires removing any known networks, as you were concerned about, and both should result in the service being disabled until turned on again using the same method.

It is important to note that if you click Turn Wi-Fi off in the method above, it is necessary to close the System Preferences window. If you reboot or shutdown without doing so, the option will not persist. Similarly, if you disable Wi-Fi from the menu bar icon (top-right of screen) the setting will not survive a reboot or shutdown.

If, as you mention, the service is activated again after following one of the methods above, I would suggest removing the service completely (by selecting it from the service list and clicking the delete or icon) then recreating it using the same settings, perhaps under a different name (e.g. WLAN Test).

Note: You can always Revert any changes you make before Applying them in Network preferences. Be careful not to lose any details that you otherwise don't have written down.


Protecting against open networks

As you suggested, it's wise to be concerned about the potential risks associated with open Wi-Fi networks, and you can at least opt out of joining these automatically:

  • Click the Apple menu (), then System Preferences, then Network
  • Click Wi-Fi or the custom-named service from the service list on the left
  • Enable the Ask to join networks checkbox:

Ask to join networks checkbox

As described, known networks will be joined automatically. If no known networks are available a selection dialog will appear on-screen, giving you the option to join any available, but unknown, Wi-Fi network.

For additional protection you can require the administrator password when changing networks:

  • Click Advanced... then enable the Change networks checkbox under the heading Require administrator authorization to:

Adjusting network service order

It's generally advisable to prioritise your network services by their reliability, from most to least reliable, to give you the best experience when using multiple connections. In your case — since WLAN traffic appears to be taking priority over other traffic — this means giving the wired thunderbolt-to-ethernet service priority over your WLAN :

  • Click the Apple menu (), then System Preferences, then Network
  • Click the gear icon (⚙), and select Set Service Order... as shown below

Network service contextual menu

  • In the panel that appears arrange the services by dragging them to the desired order, for example:

Network service order list

  • Click OK, then Apply

The system will attempt to utilise services in the order that you specified above. If a service is not available (e.g. cable disconnected, no network available) it will fall back to the next service, if any, until a valid service is found, or alternatively all services fail.

  • Thank you. This is helpful. I'd already tried both alternatives for turning off WLAN. However, I've now reduced priority of the WLAN service. Let's see if that helps. I'll wait with accepting this answer until I know which part of this answer actually helped, if any. Btw. Apple's German localization is sometimes weird. I would have never guessed that that option means "Ask to join new networks". – Roland Nov 10 '15 at 17:33
  • 1
    OK. Your first method of Turn Wi-Fi off doesn't persist, but your alternative Make service inactive seems to be what one has to do. I believe this is an example of bad user interface. If I turn something off using a provided UI element, I expect it to stay off unless I'm warned that it doesn't. Thanks again! – Roland Nov 17 '15 at 17:02
  • 2
    @Roland To simplify things further, you may want to configure multiple network 'locations'. Each 'location' can be configured with different interfaces enabled or disabled, and different settings for each. You could, for example, have a 'Home' location with your wired interface enabled and everything else disabled, and a 'Work' location with Wi-Fi enabled and everything else disabled. Switching between locations is as easy as changing the current location in the drop-down menu at the top of the Network preferences window. – soulcake Nov 17 '15 at 21:43
  • I'm sorry, but I have to unaccept this. It didn't solve the problem. Even though I have completely deactivated the WLAN service, El Capitan still occasionally tries to connect to available networks. The only difference now is that it isn't successful anymore. – Roland Dec 4 '15 at 19:30
  • @Roland Can you try disabling the "Ask to join new networks" option? – soulcake Dec 4 '15 at 20:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .