It opens a terminal at the user directory, just like clicking on the terminal icon does. I'm popping up a menu in Finder, on the folder, and the folder is outlined to indicate it is the subject of the menu, but the terminal doesn't open on that folder.

Running Yosemite 10.10.5. In Preferences>>Keyboard>>Shortcuts>>Services "New Terminal at Folder" is checked.

Any clues/pointers how to fix this?

(I just discovered this "New Terminal at Folder" feature, so I don't know if it was ever working or when it stopped working.)

1 Answer 1


I tried it and it does work but on directories (folders) only. I know that you said you selected a folder and it refuses to work but I don't have enough knowledge to understand the files in the System responsible for the correct activity.

I might recommend turning the option off and back on again. Create a new folder and immediately right click.

enter image description here

Adding a shortcut to Services Menu item

To those of you who said you are still not able to achieve the goal of adding the final step, a keyboard shortcut, this second screenshot should do it.

  • That does work, but I somehow wasn't able to assign a shortcut to it.
    – codepleb
    Commented May 8, 2017 at 13:22
  • Same here. The menu is useful for me but I would like a keyboard shortcut.
    – Scott
    Commented Nov 11, 2017 at 14:09
  • I edited my original answer with a second screenshot added to my original answer (6 years ago believe it or not) - it should do the trick.
    – Alex
    Commented Feb 11, 2021 at 2:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .