1

Right clicking on a file -> Open With -> TextEdit. Instead of opening the original file, TextEdit creates a copy of it and opens that one.

As an administrator, I have both read & write permissions. I don't see anything relevant in the App's settings.

Any ideas how to fix this?

[Added] This started happening after I had to restart the system by...pulling the plug on it. I had a hanged-up app (not TextEdit) that would ignore the Force Quit command; in fact, it wasn't even listed as a process so I had nothing to kill to begin with.

[2nd Edit] If I start TextEdit first, and open the file from within, it works. I'm thinking that this may be a LaunchServices issue.

  • What kind of file is it, and is the file stored in some kind of system/library folder? – jtheman Nov 5 '15 at 13:45
  • It is an .sh script file (execute bit is on). Located in something like ~/foo/bar...nothing special in any way. – elder elder Nov 5 '15 at 13:50
  • Can you open it with nano? – Arc676 Nov 5 '15 at 14:04
  • Yes, I can do that. – elder elder Nov 5 '15 at 14:12
  • It's probably locked, usually when TextEdit open a locked file first time it asks if you want to create a copy when opening locked files in future. It's easy to determine if it is a LaunchService issue, just boot in safe mode and try opening the file them. – user14492 Nov 5 '15 at 14:49
1

I discovered that having the Stationery pad checked under a file's properties will cause this behavior on purpose. This will create a new copy of an existing file every time it is opened, no matter the program doing so. (I suspect this flag became corrupted due to me having to "hard reset" the system.)

Of course, after all was said & done, I was able to find an explanation here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .