Recent iMacs support a "target display" mode, where you can connect another Mac using a DisplayPort cable, and the iMac will function as an external monitor.

This used to work fine, however now if the iMac is running Mac OS 10.6.7 or later (including Lion), the iMac screen will switch to 100% brightness when put into this mode, and the brightness keys on the iMac keyboard can not be used to adjust the brightness. Has anyone found a solution to this problem?

  • This seems to be a bug. The Apple Knowledge base article about target display explicitly indicates that brightness can be controlled with the iMac keyboard keys. What happens when you try to adjust brightness from the "Monitor" preference pane in "System preferences" ? – olivier Aug 11 '11 at 10:01
  • @olivier I can adjust brightness for the source (non-iMac) internal display only. If I use screen sharing to access the display preferences on the iMac, the brightness control is missing. – Tobias Cohen Aug 11 '11 at 10:07

yeah, toggling the function key setting worked for me. I'm on 17" 2011 mbp and the 27 inch cinema display with Lion.


Ctrl-F1 (which has a "dimming" circle with short marks around it) or Ctrl-F2 (which has a "bright" circle with longer marks around it)work on the external display. Dim and Bright, alone, work on the native display.

  • I run OSX 10.6.8 on a pair of 27" iMacs and have the same problem as the OP, unfortunately the Ctrl-F1 doesn't appear to work. Any other ideas? – Jagra Apr 25 '13 at 15:12

The brightness keys would sometimes work and sometimes not on the target iMac. So I solved this with a System Preference, Shades for Mac. It puts a set of sunglasses in your toolbar and you can easily adjust the brightness.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .