1

I'm connecting to a local proxy to access internet on my iPhone/iOS 9 but Twitter app seems not using the global proxy i've set for my wifi...

Other apps like Chrome & Safari are working just fine!

2
  • are any other apps not going through the proxy you set ? normally any iOS that uses NSURLConnection to make internet requests go through the settings you set in Settings -> Wifi. Maybe twitter is using cellular data instead of wifi.
    – enzo
    Commented Nov 5, 2015 at 13:42
  • I've set proxy in Settings > Wifi and as far as I've tested all apps are using it well just Twitter... I turned off cellular data, nothing changed
    – Mehdi
    Commented Nov 6, 2015 at 5:20

1 Answer 1

1

iOS 9 implements App Transport Security on each individual application. This is a setting that is enabled by default on all iOS 9 apps. Application developers that wish to allow their apps to be proxied can disable this setting in the applications plist file. If you are on a jailbroken device you can also manually modify this file.

Alternatively I found this that should work, haven't tried yet though https://nabla-c0d3.github.io/blog/2015/12/01/burp-ios9-ats/

1
  • Thank you for the contribution to this question's resolution. However, please add quotes from external link, as the answer would have lost or reduced value if the link died
    – John K
    Commented Dec 22, 2015 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .